Running letsencrypt (certbot) again doesn't create config


#1

I’m on Ubuntu 16.04, and I installed certbot and ran:
sudo letsencrypt --apache

I went through the install, it worked fine, I even ran a successful SSL test, BUT I didn’t realise the * next to a domain in the installer meant it would install certs for all those domains. (Only one domain was highlighted, just thought those asterisks were bullet points)

So I deleted /etc/letsencrypt and removed all the SSL stuff from my apache configs, and the extra .conf files it created.

Now when I run letsencrypt again I don’t get the full install procedure, I don’t get to choose, for example, whether it always redirects to HTTPS, etc… It just says “congratulations!.. etc…” but it doesn’t update the config files again. HTTPS doesn’t work anymore, and I suppose the missing config changes are the reason.

Any idea on how to proceed?


#2

I’ve manually edited the config files to get it working, by putting in my own rewrites and SSL stuff. Works fine but not being able to do it automatically took all the fun out of it :slight_smile:


#3

hi @braksator

explain the problem a bit more

what commands are you using

what are you expecting

any log files would also help

Andrei


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.