SSL Certificate | Failed to issue (Cyberpanel)

  • My domain is:
  • I ran this command: see below
  • It produced this output: see below
  • My web server is (include version): LiteSpeed 17.16
  • The operating system my web server runs on is (include version): Ubuntu 22.04
  • My hosting provider, if applicable, is: -
  • I can login to a root shell on my machine (yes or no, or I don't know): Yes
  • I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Cyberpanel 2.3 (CbPanel)
  • The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): not installed

In CbPanel I've several domains with DNS on Cloudflare, and they're working fine. Cyberpanel issued LE certificate for all of them.
For I've the same DNS records but Cyberpanel is unable to get LE certificate - so I only get Self-Signed certificate.

Here is vHost-Conf for (partial)

context /.well-known/acme-challenge {
location /usr/local/lsws/Example/html/.well-known/acme-challenge
allowBrowse 1

rewrite {

addDefaultCharset off

phpIniOverride {


And here is the output of /cyberpanel/error-logs.txt

[02.28.2023_21-21-40] Status Code: 404 for: Error: >

404 Not Found

Not Found

The requested URL was not found on this server.

Apache/2.4.52 (Ubuntu) Server at Port 80

[02.28.2023_21-21-43] /root/ --issue -d -d --cert-file /etc/letsen>
[02.28.2023_21-21-48] Failed to obtain SSL for: and:
[02.28.2023_21-21-48] Trying to obtain SSL for:
[02.28.2023_21-21-49] Failed to obtain SSL, issuing self-signed SSL for:
[02.28.2023_21-21-49] Self signed SSL issued for

Why I'm getting 404 only for and not for other websites?

Related posts
Error getting SSL certificate
acme Archives - CyberPanel


Hello @alex3232, welcome to the Let's Encrypt community. :slightly_smiling_face:

I am kind of assuming you would prefer to not share some of the other domain names.
(feel free to correct me if I am wrong)

Let's Debug is giving the The domain is being served through Cloudflare CDN. WARNING here

So what type of result do you see for your others of several domains using Let's Debug?

Also here is what I see with curl, what do your of several domains look like.

$ curl -Ii
HTTP/1.1 404 Not Found
Date: Tue, 28 Feb 2023 23:05:05 GMT
Content-Type: text/html; charset=iso-8859-1
Connection: keep-alive
CF-Cache-Status: DYNAMIC
Report-To: {"endpoints":[{"url":"https:\/\/\/report\/v3?s=RScCr53vpLlT%2F7IExV16gIys4Bya2vHvrVLIf0Gprw28eatz8U2dg1Pzg3pkl2uTYzqA1P964GI4d6LOC4hmZcBjZCKSYuy0Iu9Gubh3DoF%2Fe5vMMnLaaWnbazMEBA%3D%3D"}],"group":"cf-nel","max_age":604800}
NEL: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
Server: cloudflare
CF-RAY: 7a0ccd9379b9ef14-PDX
alt-svc: h3=":443"; ma=86400, h3-29=":443"; ma=86400

$ curl -Ii
HTTP/2 404
date: Tue, 28 Feb 2023 23:05:07 GMT
alt-svc: h3=":443"; ma=86400, h3-29=":443"; ma=86400
cf-cache-status: DYNAMIC
report-to: {"endpoints":[{"url":"https:\/\/\/report\/v3?s=g1EsxiyL9FV7DkG8JBsytcvY9nNjNajN6d6fjvdTI5pKFR%2FWy%2F1i81Ozit37oh6vOPqU%2BA5XDIPFi%2BLjyUkybeNt1ra2TpmaaxNN4gXHH5UnpRWiEZfTUpOIoeWbRA%3D%3D"}],"group":"cf-nel","max_age":604800}
nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
server: cloudflare
cf-ray: 7a0ccd9ebe418e62-PDX

Kindly wait to see if there are more knowledgeable Let's Encrypt community volunteers willing to assist.


Oh, also one more thing.

It looks like you are using, what version?

1 Like

As Bruce noted, you have this domain proxied in the DNS at Cloudflare and so are using their CDN.

Do you have the DNS proxied for the other domains that work?

And, do you have the same Cloudflare SSL settings for those? Such as the redirect settings and the Flex, Strict, choice and so on.

I am able to get a valid response from your domain even starting with http. Is there a problem other than the CyberPanel / error?

See the initial http request redirected to https and then to index.php/en and then a 200 OK result (many other headers omitted)

curl -IL
HTTP/1.1 301 Moved Permanently
Server: cloudflare

HTTP/2 301
server: cloudflare

HTTP/2 200
content-type: text/html; charset=utf-8
set-cookie: 2aa7074765f9fc31fae7ed7e84ae2121=0forel2rnm3p91qmui7ighhu1g; path=/; HttpOnly
last-modified: Tue, 28 Feb 2023 23:32:38 GMT
server: cloudflare

Hi Bruce, Mike

Thanks for your help.
Clonimi website was created (in Cyberpanel) as my other websites (*), and the same apply for the DNS records in CFlare.
I just tried LDebug (HTTP) for Clonimi and I got the error below:

ERROR: A test authorization for to the Let's Encrypt staging service has revealed issues that may prevent any certificate for this domain being issued.

I want CbPanel to issue a LE cert, not a Self-Signed one.
How do I fix this problem?

  • this one is another website of mine, same DNS records, but Full (Strict) mode in CFlare since for this one I get a proper LE cert issued through Cyberpanel, and no errors with LDebug:
    Note: SSL cert are issued through Cyberpanel after their DNS records are published in CFlare.

Another funny thing about Clonimi: once logged, the system (Joomla) lose the session after navigating 3-4 pages, and I need to login again. This doesn't happen on my local server. I'm sure it's related to the above error. --version // 3.0.6



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.