I have just moved from hostinger shared hosting to cyberpanel vps and I’ve been trying to issue a CA certified ssl for the domain helplyapp.pl

I have followed this How to Install a Free SSL on CyberPanel | Hostinger Help Center and this: How to Fix SSL Issues on CyberPanel VPS | Hostinger Help Center and also tried the solution of this kb CyberPanel Self-signed SSL certificate - Web Server - CyberPanel Community but the outcome is still the same. Cyberpanel still issues me the self signed certificate.

Here is the output after running cyberpanels command for issuing the ssl:

[root@helply ~]# /root/.acme.sh/acme.sh --issue -d helplyapp.pl -d www.helplyapp.pl --cert-file /etc/letsencrypt/live/helplyapp.pl/cert.pem --key-file /etc/letsencrypt/live/helplyapp.pl/privkey.pem --fullchain-file /etc/letsencrypt/live/helplyapp.pl/fullchain.pem -w /usr/local/lsws/Example/html -k ec-256 --force --server letsencrypt
[Mon Jan  1 12:13:53 UTC 2024] Using CA: https://acme-v02.api.letsencrypt.org/directory
[Mon Jan  1 12:13:53 UTC 2024] Multi domain='DNS:helplyapp.pl,DNS:www.helplyapp.pl'
[Mon Jan  1 12:13:53 UTC 2024] Getting domain auth token for each domain
[Mon Jan  1 12:13:55 UTC 2024] It seems the CA server is currently overloaded, let's wait and retry. Sleeping 21 seconds.
[Mon Jan  1 12:14:19 UTC 2024] Getting webroot for domain='helplyapp.pl'
[Mon Jan  1 12:14:20 UTC 2024] Getting webroot for domain='www.helplyapp.pl'
[Mon Jan  1 12:14:20 UTC 2024] Verifying: helplyapp.pl
[Mon Jan  1 12:14:20 UTC 2024] Pending, The CA is processing your order, please just wait. (1/30)
[Mon Jan  1 12:14:24 UTC 2024] Invalid status, helplyapp.pl:Verify error detail:2a02:4780:a:543:0:1972:fd24:1: Invalid response from http://helplyapp.pl/.well-known/acme-challenge/MrWvpeZOptZ3UPirXattQ0znyVao33OKmLkKxOdqkGs: 404
[Mon Jan  1 12:14:24 UTC 2024] Please add '--debug' or '--log' to check more details.
[Mon Jan  1 12:14:24 UTC 2024] See: https://github.com/acmesh-official/acme.sh/wiki/How-to-debug-acme.sh

And here are the logs:

[01.01.2024_02-01-24] Failed to obtain SSL, issuing self-signed SSL for: helplyapp.pl
[01.01.2024_02-01-25] {'my.email@hotmail.com': (554, b'5.7.1 <my.email@hotmail.com>: Relay access denied')}
[01.01.2024_02-01-25] Self signed SSL issued for helplyapp.pl.

It seems that it can’t authenticate my domain to issue a ca certificate Any ideas how fix the Cybepanel self-signed certificate problem?

Check your AAAA record and put the right IPv6 there.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.