Multiple sites without www domains on certificate

we run a reseller server using cyberpanel v2.3 (installed recently). This morning we found we had 10 sites that were failing on the www version of the domain. the non-www version has a certificate and loads fine.

The logs displayed show the command used to generate the certificates but it fails when attempting both www and non-www. it pushes on just with non-www which is successful.

EDIT: I have tested the following domain with and it came back saying it was ok

My domain is:

I ran this command (replace with above):
/root/ --issue -d -d --cert-file /etc/letsencrypt/live/ --key-file /etc/letsencrypt/live/ --fullchain-file /etc/letsencrypt/live/ -w /usr/local/lsws/Example/html -k ec-256 --force --server letsencrypt

It produced this output:
Failed to obtain SSL for: and:
Trying to obtain SSL for:
Successfully obtained SSL for:

My web server is (include version):

The operating system my web server runs on is (include version):
ubuntu 20.04

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
cyberpanel v2.3

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Hi @brellatech, and welcome to the LE community forum :slight_smile:

I have one word for that:

And why would you purposely use to overwrite files within the certbot folders?
Do you NOT have control of the web server configuration files?

I think you have made things overcomplicated.


Here is the most recent issued certificate | 8773427153
It only has and no in the SANs.

Or a different view:
and www

1 Like

Oehh, mixing the Certbot directory in /etc/letsencrypt and probably can lead only to many issues. I would not recommend.

Also, as Rudy said, please don't use the --force option. It usually doesn't magically make all your issues go away.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.