Failed to get certificate with http challegne

When requesting a certificate i got the below error.
sudo certbot certonly --standalone --debug-challenges --preferred-challenges http -d
I see that the web server is responding
"ACME client standalone challenge solver"
either locally and from

How can I troubleshoot it?

My domain is:

I ran this command: sudo certbot certonly --standalone --preferred-challenges http -d

It produced this output:
The Certificate Authority failed to download the challenge files from the temporary standalone webserver started by Certbot on port 80. Ensure that the listed domains point to this machine and that it can accept inbound connections from the internet.

My web server is (include version):
let's encrypt home assistant addon
The operating system my web server runs on is (include version): debian 11

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Your website does not respond on port 80 nor port 443 nor on pings.

Please make sure the IP address is correct and any firewall or router accepts port 80 (and 443) and it's correctly portmapped, if applicable.

1 Like

I stopped the certbot... if you try now you should get the response...

Nope, just time outs. Certbot running or not wouldn't have mattered with these timeouts.

1 Like

those are 2 different domain names

When --debug-challenges is paused, try a mobile phone with wifi off to use the carrier's public network to reach the domain


You're right!! is resolved from my router.
Tried on another network connection and it didn't work!
So the problem seems that my router is handling port mapping in a strange way...
Thanks for pointing me to the right direction!!!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.