(solved) Renew Certificate Failed (Timeout during connect)

My domain is: bbb.arherstal.be

I ran this command: certbot renew

It produced this output:

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Processing /etc/letsencrypt/renewal/bbb.arherstal.be.conf
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Cert is due for renewal, auto-renewing...
Plugins selected: Authenticator webroot, Installer None
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for bbb.arherstal.be
Waiting for verification...
Cleaning up challenges
Attempting to renew cert (bbb.arherstal.be) from /etc/letsencrypt/renewal/bbb.arherstal.be.conf produced an unexpected error: Failed authorization procedure. bbb.arherstal.be (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching https://bbb.arherstal.be/.well-known/acme-challenge/Nsf-13WlvKBNmcnxmjyXic0v8AV2dsvKGI0KFCIzh4Q: Timeout during connect (likely firewall problem). Skipping.
All renewal attempts failed. The following certs could not be renewed:
  /etc/letsencrypt/live/bbb.arherstal.be/fullchain.pem (failure)

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

All renewal attempts failed. The following certs could not be renewed:
  /etc/letsencrypt/live/bbb.arherstal.be/fullchain.pem (failure)
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
1 renew failure(s), 0 parse failure(s)

IMPORTANT NOTES:
 - The following errors were reported by the server:

   Domain: bbb.arherstal.be
   Type:   connection
   Detail: Fetching
   https://bbb.arherstal.be/.well-known/acme-challenge/Nsf-13WlvKBNmcnxmjyXic0v8AV2dsvKGI0KFCIzh4Q:
   Timeout during connect (likely firewall problem)

   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A/AAAA record(s) for that domain
   contain(s) the right IP address. Additionally, please check that
   your computer has a publicly routable IP address and that no
   firewalls are preventing the server from communicating with the
   client. If you're using the webroot plugin, you should also verify
   that you are serving files from the webroot path you provided.

My web server is (include version): Nginx

The operating system my web server runs on is (include version): Unbuntu 16.04

My hosting provider, if applicable, is: ovh.net

I can login to a root shell on my machine (yes or no, or I don't know): yes

I don't get it. bbb.arherstal.be is available on port 80 and 443. The site respond coirrectly to request.
The token is well created by certbot in the webroot directory during the renewal procedure.
OVH firewall is not enabled and ufw has 80 and 443 open.

1 Like

Hello @lgomez,

Let's Encrypt, if available, will try to use your IPv6 address and you have one defined in your domain but your server doesn't answer IPv6 requests, only IPv4.

So, fix the issue with your firewall/web server or remove the AAAA record for your domain.

Cheers,
sahsanu

2 Likes

Thx, i will try that.

2 Likes