Timeout when renewing certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: https://lakehillshortmat.now-dns.org/

I ran this command: /usr/bin/certbot renew --preferred-challenges http --pre-hook “service apache2 stop” --post-hook “service apache2 start”

It produced this output: Saving debug log to /var/log/letsencrypt/letsencrypt.log


Processing /etc/letsencrypt/renewal/lakehillshortmat.now-dns.org.conf

Cert is due for renewal, auto-renewing…
Running pre-hook command: service apache2 stop
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for lakehillshortmat.now-dns.org
http-01 challenge for lasalle.now-dns.org
Waiting for verification…
Cleaning up challenges
Attempting to renew cert from /etc/letsencrypt/renewal/lakehillshortmat.now-dns.org.conf
produced an unexpected error: Failed authorization procedure. lasalle.now-dns.org (http
-01): urn:acme:error:connection :: The server could not connect to the client to verify
the domain :: Fetching http://lasalle.now-dns.org/.well-known/acme-challenge/54NQ_6QaZ9K
t1lejFm6X-ocCQ8cet-Whs8c23wCddR4: Timeout during connect (likely firewall problem). Skip
ping.

All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/lakehillshortmat.now-dns.org/fullchain.pem (failure)
Running post-hook command: service apache2 start
1 renew failure(s), 0 parse failure(s)

IMPORTANT NOTES:

  • The following errors were reported by the server:

Domain: lasalle.now-dns.org
Type: connection
Detail: Fetching
http://lasalle.now-dns.org/.well-known/acme-challenge/54NQ_6QaZ9Kt1lejFm6X-ocCQ8cet-W
hs8c23wCddR4:
Timeout during connect (likely firewall problem)

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A record(s) for that domain
contain(s) the right IP address. Additionally, please check that
your computer has a publicly routable IP address and that no
firewalls are preventing the server from communicating with the
client. If you’re using the webroot plugin, you should also verify
that you are serving files from the webroot path you provided.

My web server is (include version): Apache 2.4

The operating system my web server runs on is (include version): debian linux version 9

My hosting provider, if applicable, is: shaw.ca

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.10.2

I am 99.99% coinfident that incoming port 80 is not blocked by my ISP: I got my neighbour to connect via http, and I tried the same thing using a virtual machine whose network connection is via a VPN, I also managed to telnet to port 80.

This certificate renew with no problem several times already this year and I am 99.99% certain that I have changed nothing that would affect it (only changes I made were to the web app running on the server).

thanks in advance for your help.

1 Like

OK, solved my own problem. There were two different domain names associated with the same IP address.

or, rather, it should have been the same IP, but one of the domain names had not been updated and was resolving to an out-of-date IP.

Having updated the IP at now-dns.org, everything is now OK.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.