Certbot renewal timeout


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: devolved.noip.me

I ran this command: certbot renew

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log


Processing /etc/letsencrypt/renewal/devolved.noip.me.conf


Cert is due for renewal, auto-renewing…
Plugins selected: Authenticator apache, Installer apache
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for devolved.noip.me
Waiting for verification…
Cleaning up challenges
Attempting to renew cert (devolved.noip.me) from /etc/letsencrypt/renewal/devolved.noip.me.conf produced an unexpected error: Failed authorization procedure. devolved.noip.me (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://devolved.noip.me/.well-known/acme-challenge/8o8clQ5P8WoqkT1OaxBk4mPcu7HuhAKi7KR8mX3Sk8M: Timeout during connect (likely firewall problem). Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/devolved.noip.me/fullchain.pem (failure)


All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/devolved.noip.me/fullchain.pem (failure)


1 renew failure(s), 0 parse failure(s)

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: devolved.noip.me
    Type: connection
    Detail: Fetching
    http://devolved.noip.me/.well-known/acme-challenge/8o8clQ5P8WoqkT1OaxBk4mPcu7HuhAKi7KR8mX3Sk8M:
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version): www-servers/apache-2.4.34

The operating system my web server runs on is (include version): Gentoo Linux (Kernel v. 4.14.63)

My hosting provider, if applicable, is: noip.com

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

This is a personal server, so I try to make it a simple apache setup. I’ve used Lets Encrypt (managed by certbot) for a year or two now and have it set to auto renew a month in advance (As is suggested). I came across this error once before, but I had accidentally disabled port 443 on my router. Both 443 and 80 are currently open (I usually keep 80 closed, but opened it to try to figure out what’s wrong here). I can access my website internally and externally. Neither my access_log or ssl_access_log appear to get any entries while running certbot renew (I’ve been running tail -fin a separate console window) so it may well be a firewall issue, but there haven’t been any changes that I can think of which would have affected certbot.


#2

I can access https://devolved.noip.me/ but http://devolved.noip.me/ times out. Are you completely sure there isn’t a firewall blocking access from external networks?


#3

@mnordhoff That was oddly helpful. I had tested with stopping my server firewall and ensured that my router’s firewall allowed 80 and 443, but it seems that the server firewall restarted at some point (and I swore that I had checked it briefly too). In any case, thanks. It seems to be working now that the server stopped (albeit just for the update). I may script this for future renewals.