Reverting to http after removing installation


#1

After trying to install with ./letsencrypt-auto, I’ve decided to go back to http for now, since I:

  1. Couldn’t get letsencrypt working easily due to a bug with WSGI applications
  2. Don’t care enough to try harder, since my site is pretty low in traffic

I tried to do this by deleting the directories mentioned here. I also ran a sudo a2dissite for each conf file with le-ssl in the name.

Now, when I visit my site, Safari and Chrome both still try to use https, and fail with messages like “This site can’t provide a secure connection.”

How can I completely revert back to http, having already deleted directories before I read about the rollback option?


#2

Can you provide your site address so we can check it out? It sounds like you may have a redirect still configured in your Apache config.


#3

Sure, it’s at http://deentaylor.com/. It’s supposed to redirect to http://luke.deentaylor.com/ (which works fine over HTTP)

I have already removed the RewrtiteRules from the bottom of my apache cons files.


#4

It appears that it works when clicking on the link, but if I put deentaylor.com into Safari, it tries to access a https version of the site. Now it seems to me like this is just an issue with browser caching. Sorry for the inconvenience.


#5

No problem! Glad it worked out.