Renew cert Max retries exceeded with url: /directory

My domain is: plimsoftware.pt

I ran this command: sudo certbot renew

It produced this output:

Processing /etc/letsencrypt/renewal/www.plimsoftware.pt.conf


Cert is due for renewal, auto-renewing...
Plugins selected: Authenticator standalone, Installer None
Attempting to renew cert (www.plimsoftware.pt) from /etc/letsencrypt/renewal/www.plimsoftware.pt.conf produced an unexpected error: HTTPSConnectionPool(host='acme-v02.api.letsencrypt.org', port=443): Max retries exceeded with url: /directory (Caused by NewConnectionError('<urllib3.connection.VerifiedHTTPSConnection object at 0x7f3e1216b2b0>: Failed to establish a new connection: [Errno -3] Temporary failure in name resolution',)). Skipping.

My web server is (include version): nginx/1.14.0 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 18.04.4 LTS

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.27.0

Anybody can help? Thanks!

1 Like

This suggests to me that the DNS resolving capabilities on your server are broken. Can you test that by running host acme-v02.api.letsencrypt.org please?

2 Likes

I have my site in a VM on Google Cloud Platform. Running host acme-v02.api.letsencrypt.org i have the following: ;; connection timed out; no servers could be reached.

Same result with host google.com

1 Like

That means your VMs DNS resolving doesn't work in general and it's is not related to Let's Encrypt.

1 Like

I resolved doing

sudo systemctl restart systemd-resolved.service

:grinning: :grinning:

5 Likes

I'd recommend checking sudo apt-get update to see if there are some updates to install as systemd-resolved should be pretty hard to crash, normally.

5 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.