Problem updating cert-bot OSX

I followed the approach by JeffTheRocker some time ago to set up Let’s Encrypt on my OSX Server (5.3.1 OSX 10.12.6). All has worked fine, through several renewals until the current when I get:

Automated Get certificate failed:
Upgrading certbot-auto 0.15.0 to 0.17.0…
Couldn’t download <urlopen error [SSL] unknown error (_ssl.c:661)>

Any advice would be appreciated.

Are you able to wget that file without issue? It loads fine and without any SSL warnings for me.

Thank you, I was not able to get the file with curl - I do not have wget available.

After digging in a little, I should add I am far from an expert, I thought it might have something to do with the approach I initially used to obtain the certificate so changed from the JeffTheRocker approach to a pure homebrew approach as described here.

Worked perfectly - all now up and running correctly :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.