Instruction for other unix not working

Hello,
after not seeing my distribution, tried instruction for other unix, specifically to wget https://dl.eff.org/certbot-auto … it failed to upgrade itself talking about unsupported system, then failed to get certificate talking about ACME 1 no longer being supported.

Your system is not supported by certbot-auto anymore.
Certbot will no longer receive updates.
Please visit https://certbot.eff.org/ to check for other alternatives.
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Certbot doesn’t know how to automatically configure the web server on this system. However, it can still get a certificate for you. Please run “certbot-auto certonly” to do so. You’ll need to manually configure your web server to use the resulting certificate.

Please enter in your domain name(s) (comma and/or space separated) (Enter ‘c’
to cancel): bluestar.servehttp.com
Obtaining a new certificate
An unexpected error occurred:
The client lacks sufficient authorization :: Error creating new authz :: Validations for new domains are disabled in the V1 API (End of Life Plan for ACMEv1)
Please see the logfiles in /var/log/letsencrypt for more details.

Could you update the recommended default client to use the V2 API somehow? It would also be nice if it didn’t required root. Note that I’m completely ok with the “certonly” mode.

1 Like

What is your distribution?

It might be possible to use your installed version of certbot-auto with ACMEv2, but it depends what version it is currently:

certbot-auto --version 

It’s possible, but you need to nominate a --logs-dir, --conf-dir and --work-dir, or set the equivalent in your cli.ini.

1 Like

It’s 0.19.0 … and, to repeat, it’s the version available on https://dl.eff.org/certbot-auto as provided in instructions … I suspect it’s not exactly last version.

The way that certbot-auto works is that it downloads the latest version that is released. Currently, that’s 1.6.0.

You’re stuck at 0.19.0 because certbot-auto doesn’t have a strategy to download the right dependencies for your distro, and the most recent version it downloaded onto your system was 0.19.0.

Could you share what your distro is? I’d be happy to recommend the next best way to install Certbot or even an alternate ACME client for you.

2 Likes

It’s Gentoo.
… and I see it actually is on the list, I must’ve missed it earlier. Doesn’t explain why the certbot wasn’t able to update itself on it. Unless it’s instructions are old enough the package names changed meanwhile or something …

Note: I’m currently trying to install 1.3.0 from distribution.

1 Like

Ok.
The 1.3.0 from distribution worked.
As I predicted, problem is just in the instructions for “other Unix”. Wouldn’t had any problem if I noticed Gentoo in that list on first try :slight_smile: … which I probably would, if it was sorted by something like alphabet and not randomly.

1 Like

Thanks @hkmaly, I created this issue

to discuss the order of the distributions in the Certbot website drop-down.

1 Like

That would be definitely good idea, however I still think that there should be working client for generic unix, for case you are missing some. Granted, that likely would be more complicated than just changing the order …

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.