Problem renewing certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: policy.animaljusticeparty.org

I ran this command: sudo certbot certonly -d policy.animaljusticeparty.org

It produced this output:


Cert is due for renewal, auto-renewing…
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for policy.animaljusticeparty.org
Cleaning up challenges
Problem binding to port 80: Could not bind to IPv4 or IPv6.

IMPORTANT NOTES:

  • Your account credentials have been saved in your Certbot
    configuration directory at /etc/letsencrypt. You should make a
    secure backup of this folder now. This configuration directory will
    also contain certificates and private keys obtained by Certbot so
    making regular backups of this folder is ideal.

My web server is (include version): nginx 1.14.0

The operating system my web server runs on is (include version): Ubuntu 18.04.2

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.23.0

Do I need to shutdown nginx before running this command?

1 Like

Hi @GeoffRussell

looks like you use the standalone authenticator. Then you have to stop your running webserver.

What’s the content of your renewal file, located in

/etc/letsencrypt/renewal
  • Stop your running webserver (not so good)
  • use --nginx or --webroot to use your running webserver.
1 Like

Many thanks … stopping and starting is okay for now … next time I’ll keep the --nginx option in mind. All good.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.