Problem issuing new certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:paraglide.co.uk

I ran this command: Let's debug found All OK!
OK
No issues were found with paraglide.co.uk.

It produced this output:Could not issue an SSL/TLS certificate for paraglide.co.uk
Details
Could not issue a Let's Encrypt SSL/TLS certificate for paraglide.co.uk. Authorization for the domain failed.

Details
Invalid response from https://acme-v02.api.letsencrypt.org/acme/authz-v3/7439420892.

Details:

Type: urn:ietf:params:acme:error:dns

Status: 400

Detail: DNS problem: NXDOMAIN looking up TXT for _acme-challenge.paraglide.co.uk - check that a DNS record exists for this domain

My web server is (include version):

The operating system my web server runs on is (include version):CentOS Linux 7.8.2003 (Core)

My hosting provider, if applicable, is:ionos1&1

I can login to a root shell on my machine (yes or no, or I don't know):no

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):Plesk Obsidian
Version 18.0.30 Update #1, last updated on Sept 22, 2020 06:03 AM

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Hi @aberbuddha

if you use Plesk and if the Plesk integrated ACME client doesn't work, please ask your hoster.

It's the job of your hoster to support Plesk.

Thanks for the reply, I manually uploaded a TXT record and it is working now, but it should work automatically with ACME?

Yes, it should. Why? I don't know. Your hoster has to fix that.

Welcome to the Let's Encrypt Community, Steve :slightly_smiling_face:

It looks to me like your TXT record is fully accessible:
_acme-challenge.paraglide.co.uk. 3599 IN TXT "9FXRznl0VKD_xfseqMQlQTFnvOaUN14PbLRjCJ5BIgc"

It's possible that the record just had not yet propagated when you tried to authenticate. You sometimes need to delay a bit. You can use the following tool to see if a record currently exists:

If you have more questions, I'm happy to help. Here's some official documentation if you want some reference materials:


Getting Free SSL/TLS Certificate from Let’s Encrypt


Congratulations! You got your certificate! :partying_face: