Plugin certbot-dns-route53 doesn't exist on brew (OSX)

In this doc page for OSX, the installation steps are:

  1. $ brew install certbot
  2. $ brew install -PLUGIN_NAME

(1) worked fine

For (2) I have tried the following:
$ brew install route53
$ brew install -route53
$ brew install dns-route53
$ brew install -dns-route53
$ brew install certbot-dns-route53
$ brew install -certbot-dns-route53

The response I'm getting is "No available formula with the name xxxxxxx"

How can I install this plugin on OSX please?

Thank you

1 Like

Hi @welljim, and welcome to the LE community forum :slight_smile:

macOS can be a bit tricky...
Have you tried?:
Install certbot-dns-route53 on macOS with MacPorts


I haven't. I've been reading online that mixing Brew with MacPorts is not recommended and that it's better to stick to one of the two package managers to avoid dependency nightmares :grimacing:

Hm, I'm not sure why it says that. Homebrew does not support any of the plugins in their formula/api/repo.

Here's an open ticket about the plugins on Certbot. There was an old workaround, and there is a new workaround. Depending on what version of homebrew/formula you have, one should work:



I just found that second ticket and will rephrase @_az's advice presented in it:

You should not use homebrew, and instead install certbot (and all plugins) from pip.



I did $ brew uninstall certbot and then followed the instructions here to install via pip. All good now.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.