1.3.0: authenticator plugin not found (certbot-inwx-dns)

Hi all,

macOS user here having trouble with plugin for dns challenge.

I am using a wildcard cert *.kimpenhaus.net in my local network. I renewed it several times successful with certbot already (executing the same command). But after the latest update (from 1.0.0 in January) to 1.3.0 I can’t get it work. My guess is that the plugin itself is not in the search path of certbot, but I can’t get it fixed.

some background information:

  • certbot is installed via homebrew and on version 1.3.0 (HEAD)
  • plugin is certbot-dns-inwx which is installed via pip3: pip3 install certbot-dns-inwx
  • error is: certbot: error: unrecognized arguments: --certbot-dns-inwx:dns-inwx-credentials /Users/k/Documents/git/lets-encrypt/config/inwx.cfg

I used to have this error after prior updates but from what I understood it came from switching away from virtualenv on one of the former updates (and I got it fixed by installing the plugin into global site-packages). Since january (my last renewal) I can’t see any major changes so I can’t understand why this is not working anymore. All my estimations to print out out certbots search path failed - event thou I used to --verbose I can’t get any information on why the plugin isn’t found.

As time is running out - my cert is still valid unitl 2020-04-02 - I would like to have it working again :slight_smile: So any help is appreciated.

I am little unsure if this is somewaht a special setup as I can’t find much related information nor am I sure if this is related to homebrew setup constellation or changes in certbot in 1.1.0/1.2.0 or 1.3.0 ( last working version was 1.0.0).

answers to questions from help template:

My domain is:

  • wildcard cert: *.kimpenhaus.net (but behind firewall in a local network not accessible from the internet)

I ran this command:

 certbot renew --verbose -a certbot-dns-inwx:dns-inwx \
--certbot-dns-inwx:dns-inwx-credentials ~/Documents/git/lets-encrypt/config/inwx.cfg \
--logs-dir ~/Documents/git/lets-encrypt/logs \
--config-dir ~/Documents/git/lets-encrypt/config \
--work-dir ~/Documents/git/lets-encrypt/ \
--server https://acme-v02.api.letsencrypt.org/directory \
--deploy-hook ~/Documents/git/lets-encrypt/config/renewal-hooks/deploy/deploy.sh \
--force-renewal

It produced this output:

usage:
  certbot [SUBCOMMAND] [options] [-d DOMAIN] [-d DOMAIN] ...

Certbot can obtain and install HTTPS/TLS/SSL certificates.  By default,
it will attempt to use a webserver both for obtaining and installing the
certificate.
certbot: error: unrecognized arguments: --certbot-dns-inwx:dns-inwx-credentials /Users/k/Documents/git/lets-encrypt/config/inwx.cfg

My web server is (include version):

  • none -> dns challenge

The operating system my web server runs on is (include version):

  • macOS 10.15.3 Catalina

My hosting provider, if applicable, is:

  • none

I can login to a root shell on my machine (yes or no, or I don’t know):

  • I think it's not relevant - but yes I can (but didn't needed to in the past)

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

  • I think it's not relevant abd I run the command from the shell

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

  • certbot 1.3.0

If any further information is need to get help, I happily provide :slight_smile:

Thanks for your time and help!

m.

I don’t use this plugin; but I would try reinstalling it

tried pip3 uninstall certbot-dns-inwx as well as
brew uninstall certbot and then reinstall with
pip3 install certbot-dns-inwx and brew install certbot with no luck :frowning_face:

also tried pip3 install --prefix $(brew --prefix certbot) certbot-dns-inwx with the same results…

Hi @kimpenhaus

I’m not firm with that inwx-plugin.

But your error says, that Certbot doesn’t understand your command.

May be the “:” is a problem.

Perhaps remove the

--certbot-dns-inwx:dns-inwx-credentials ~/Documents/git/lets-encrypt/config/inwx.cfg

and check, if Certbot asks.

1 Like

Thanks for the suggestion @JuergenAuer - I tried and it produces following output (just made a screenshot):

It complains about missing attribute certbot-dns-inwx:dns-inwx-credentials - any idea? Might it be that the plugin is not compatible with v1.3.0?

Gnaaa - my fault - it was still in the conf:

after commenting out it just says:

So i think it is an issue with installation path or search path inside certbot - any idea where it is looking for that plugin?

Got it … :face_with_monocle:

so after upgrading some pip3 installed packages (certbot and acme) it went smooth as last time…

sorry for taking your time - and thanks for your suggestions.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.