Operation failed.Login in to DSM again and retry

Could you please help me to understand what’s the problem, i’m trying to issue letsencrypt certs for my domain via Synology, and facing same error all the time, just a day ago it worked good for issuing it for DDNS.

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: fishy.rocks

I ran this command: trying to create certificate via DSM

It produced this output: Operation failed.Login in to DSM again and retry.

My web server is (include version): none unless it’s Webstation app

The operating system my web server runs on is (include version): DSM 6.2.2-24922 Update 3

My hosting provider, if applicable, is: n/a

I can login to a root shell on my machine (yes or no, or I don’t know): no

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): DSM 6.2.2-24922 Update 3

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): n/a

Hi @stan_marsh

is this really your domain? If yes, that can't work.

First, there are two different ip addresses - https://check-your-website.server-daten.de/?q=fishy.rocks

Host T IP-Address is auth. ∑ Queries ∑ Timeout
fishy.rocks A Cologne/North Rhine-Westphalia/Germany (DE) - SEDO GmbH No Hostname found yes 1 0
AAAA yes
www.fishy.rocks A Cologne/North Rhine-Westphalia/Germany (DE) - SEDO GmbH No Hostname found yes 1 0
A Moscow/Russia (RU) - Moscow Local Telephone Network (OAO MGTS) Hostname: 95-165-129-42.static.spd-mgts.ru yes 1 0
AAAA yes

On in Germany, one in Moscow.

Second, the 91.* ip has a domain parking script. The 95.* looks like a Webstation.

Perhaps remove the 91.* ip address, so Letsencrypt sees the correct content of the validation file, not the parking page.

1 Like

That a very weird thing.
I have only 1 managed dns record, and had no idea about 2nd ip address. How can I remove 91.* ip address?

UPD> Seems like I figured it out. Problem was in improper management of DNS records at domain provider.
Thank you!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.