Problem to create Certificate on Synology DS718+ with actual DSM-OS


#1

Hi all, some issue on my Synology DS718+ with actual DSM/OS

My Synology ist behind a AVM FritzBox Router and the internal IP is defined as exposed host, so every port is free. On the router there was the DDNS defined.
The call to my domain was working

My domain is: www.weidmueller-cloud.de

I ran this command: using UI of Synology DSM/OS

It produced this output: “Verbindung zu Let’s Encrypt konnte nicht hergestellt werden. Achten Sie darauf, dass der Domain-Name gültig ist” (EN: “Connection to Let’s Encrypt could not be established. Make sure the domain name is valid”

My web server is (include version): Synology Web Server (actual version)

The operating system my web server runs on is (include version): DSM/OS with NGINX

My hosting provider, if applicable, is: My Synology DiskStation

I can login to a root shell on my machine (yes or no, or I don’t know): no

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): DSM UI

I have three fileds to fill:

If I type into browser “weidmueller-cloud.de” I get to my web-server on www.weidmueller-cloud.de. If I use subdomain www.weidmueller-cloud.de, it also works.
All ports are free because of exposed host.

What do I do wrong?


#2

If the setup is still the same then the problem could be that weidmueller-cloud.de doesn’t resolve to your Synology but instead to some webspace at your provider. I think that the domainname is the essential entry to resolve to your Synology. At the moment the Domain weidmueller-cloud.de gives me the following result: “Diese Domain ist unkonfiguriert.”

Could it be that you are running your own DNS in your internal net that points weidmueller-cloud.de to your Synology?


#3

Here is guide for you:



#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.