Synology failed to Connect - Check Domain Name

LetsEncrypt on Synology DSM 6.2.2-24922 Update 4 I can get a certificate for the defult Synology sddress. After a number of years my cert expired and now I cannot renew it. I have deleted it and tried to get a new cert.

My domain is:

I ran this command: Control Panel —>Security —>Certificate -->Create Certificate

It produced this output: Failed to connect to Let’s Encrypt. Please make sure the domain name is valid

My web server is (include version): DSM Web Station

The operating system my web server runs on is (include version):Synology DSM

My hosting provider, if applicable, is: Web Station by Synology

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): Synology DSM

1 Like

This looks like it should be working ok.

The regular requests get redirected but the challenge requests are handled correctly:

curl -Iki
HTTP/1.1 302 Moved Temporarily
Date: Mon, 20 Apr 2020 22:28:20 GMT
Content-Type: text/html
Content-Length: 138
Connection: keep-alive
Keep-Alive: timeout=20

curl -Iki
HTTP/1.1 404 Not Found
Date: Mon, 20 Apr 2020 22:28:42 GMT
Content-Type: text/html
Content-Length: 11939
Connection: keep-alive
Keep-Alive: timeout=20
Vary: Accept-Encoding
ETag: "5cd4a4d8-2ea3"

I would try and try again or try to find any log file entries that might give us a clue.

1 Like

I’ve been trying for 3 months now…several times a day. But not all at once…Anthing else?

Logs from Where? in the DSM. Give me a directory to look for one.

1 Like

Yes, the DSM
That is a question for Synology.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.