Not receiving email alerts anymore


#1

Good morning
I am not receiving any emails anymore for when my certificates are going to expire.
I can not find where to re-enter this. can anybody help me ?

thanks in advance.
Carolyn


#2

Did you accidentally click an unsubscribe link? The link unsubscribes you from all expiry notifications, not just a particular certificate or domain.

I don’t believe there’s currently any way to re-subscribe with the same email address, but you can change the email address on your account and it will subscribe the new one. As https://letsencrypt.org/docs/expiration-emails/ says:

However, you can change the email address on your account, which effectively re-subscribes you. Many common email services treat yourname+1@example.com the same as yourname@example.com. So if you update your email address to yourname+1@example.com, you can start getting expiry mail again. With Certbot, use:

~/certbot/venv/bin/certbot register --update-registration --email yourname+1@example.com

(or instead of ~/certbot/venv/bin/certbot just use certbot or certbot-auto or whatever, depending on how you installed it)


#3

Hi
Thanks for your speedy reply.
I don’t think i did, but i’m guessing that it must probably be the case.

I’ve seen the instruction you sent on how to change the email address using certbot, but i don’t think i’m using certbot.
To be honest, i’m not a developper (and i’m blonde to boot!)
I did the following to install letsencrypt :

To install letsencrypt utility i typed : sudo apt-get install -y letsencrypt

Then to lauch lets Encrypt certification I typed : sudo letsencrypt certonly -d domainename.com
And entered the e-mail address

Each time i renew, i just type :
sudo letsencrypt certonly -d domainename.com

So I’m not sure what i should now type to re-enter an email address.
Should i retype : sudo letsencrypt --update-registration --myemain@domain.com

Thanks in advance for your help and patience.
Carolyn


#4

letsencrypt and certbot are the same thing, it just got renamed a while ago. The command you posted should work, but note that the --update-registration option was added in version 0.8.0 so if you have an older version it won’t work and you might need to upgrade it. You can find what version you’re using by typing letsencrypt --version

If you need help upgrading letsencrypt/certbot, let us know what operating system you’re using.


#5

Sorry, just noticed a couple of errors in this, it should actually be

sudo letsencrypt register --update-registration --email myemain@domain.com

#6

ok… i checked the version of letsencrypt on one of my servers (there are 5 in all) is 0.4.1
So i guess i need to update my letsencrypt.

I connect to my distant server (on which I’ve installed letsencrypt) using PuTTY since i have a windows pc.

The distant servers are OVH vps

Carolyn


#7

I tried this, just in case we’d have any luck, but i got the following error message :

unrecognized arguments: register --update-registration


#8

Right, you’ll need to upgrade first.

Do you know what operating system is running on the VPS? Ubuntu, Debian, CentOS, something else? Ubuntu 16.04 packages letsencrypt 0.4.1 so that might be what you’ve got?

Also, what web server are you using? Apache, nginx, etc?

The instructions for installing and using the latest version of certbot are at https://certbot.eff.org/ but you need to know the operating system and web server.


#9

It’s Linux Ubuntu 16.04 but I can’t find on the OVH site what web server is used (and you don’t get the choice when configuring the server) so I’ll check with OVH tomorrow for the web server.
thanks so much for your help today :slight_smile:

Carolyn


#10

We can probably figure it out if you tell us the domain name…


#11

Well all my servers are at the domain haapie.com
so for example, i have sandbox.fr.haapie.com


#12

I can’t seem to connect to the sandbox subdomain, but it looks like haapie.com is using Apache.

So the correct instructions would be here.


#13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.