Not padlock on website

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: SSL generated

It produced this output: No paddlock shows at sometimes

My web server is (include version): shared server OVH linux

The operating system my web server runs on is (include version): WP

My hosting provider, if applicable, is: OVH Cloud

I can login to a root shell on my machine (yes or no, or I don't know): YES

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): YES

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): no idea

Welcome to the community @taraT

I don't see anything wrong with your certs. I used this SSL Checker (link here)

But, your HTTP domain name is not redirecting to HTTPS. People might not get your HTTPS site if they just type the domain name (some browsers will, some won't).

See below site. It's "More Info" link describes one option for Apache. Or, perhaps your WP config can control this.


Hi Mike,
Thanks for your reply.
Would you be able to explain how to force the HTTPS ? My web host is OVH and they won't help.
That's what they wrote : there is only to activate a redirect from http to https and we cannot help you in any way.
I am using a shared server on OVH Cloud.


I'd search the web for how to forward HTTP to HTTPS in WP.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.