No valid IP addresses found for

Hi,
I am trying to host my (first) website with nginx via ubuntu on a vm instance with google cloud, on a domain registered with google domains. I mostly followed the steps outlined through this guide.

I can access the website via the IP address but not via the url, which is probably why I’m getting the following error but I cannot work out how to fix it .

My domain is: ownintothefoam.com

I ran this command: sudo certbot --nginx certonly

Gives output:

Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org
Which names would you like to activate HTTPS for?
1: ownintothefoam.com
2: www.ownintothefoam.com
Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter 'c' to cancel): 1
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for ownintothefoam.com
Waiting for verification...
Cleaning up challenges
Failed authorization procedure. ownintothefoam.com (http-01): urn:ietf:params:acme:error:dns :: No valid IP addresses found for ownintothefoam.com
IMPORTANT NOTES:
The following errors were reported by the server:
   Domain: ownintothefoam.com
   Type:   None
   Detail: No valid IP addresses found for ownintothefoam.com

My web server: Nginx 1.10.3
The operating system my web server runs on: 16.04 LTS
My hosting provider: Google
I can login to a root shell on my machine: yes
I’m using a control panel to manage my site: no
The version of my client: 0.31.0

My custom resources on domains.google:

My name servers are set to use google name servers.

My sites-available/sites-enabled file:

server {
  listen 80 default_server;
  listen [::]:80 default_server;
  root /var/www/ownintothefoam.com;
  index index.html;
  server_name ownintothefoam.com www.ownintothefoam.com;
  location / {
    try_files $uri $uri/ =404;
  }
}

Any help is much appreciated.

1 Like

Hi @owninthefoam

checking your domain there is no ip address - https://check-your-website.server-daten.de/?q=ownintothefoam.com

Host Type IP-Address is auth. ∑ Queries ∑ Timeout
ownintothefoam.com A yes 1 0
AAAA yes
www.ownintothefoam.com Name Error yes 1 0
*.ownintothefoam.com A Name Error yes
AAAA Name Error yes
CNAME Name Error yes

But ownintothefoam.com.ownintothefoam.com has one.

So your dns entry is wrong, your menu adds the domain name.

Use @ instead, then recheck your domain.

2 Likes

Oh I understand now!
I have added the @ entry and it worked.
Thank you!

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.