Problems Creating Certificate Failing

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: sudo certbot --nginx -d -d

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. (http-01): urn:ietf:params:acme:error:dns :: No valid IP addresses found for


My web server is (include version): Digital Ocean

The operating system my web server runs on is (include version): Ubuntu 18.04

My hosting provider, if applicable, is: Digital Ocean

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

There is no DNS IP for the base name:


Addresses: 2604:a880:800:c1::18d:4001

But why does it say that if I can access my website correctly.

Because browsers are too smart and add www by themselves. Copy the addresses to the base domain too.

You currently have:

www IN A
www IN AAAA 2604:a880:800:c1::18d:4001

You should have:

@   IN A
@   IN AAAA 2604:a880:800:c1::18d:4001
www IN A
www IN AAAA 2604:a880:800:c1::18d:4001

Does it takes time to reflect the change? I added @ in A and @ in AAA in my Digital Ocean.

Few seconds to few minutes

Thanks you the best!!! How do you know all this? I can know all programming languages but if I don’t know how to configure a server it makes no sense.

Sometimes you need to read the source documents:

Thanks for sharing. Hopefully someone else in here will find this very useful.

But now i try to do a re run for renewal to see if it will renew and i get the same error as before.

how you get this information?

show me the whole log.

now it worked. so interesting. Where can i get

@   IN A
@   IN AAAA 2604:a880:800:c1::18d:4001
www IN A
www IN AAAA 2604:a880:800:c1::18d:4001

where can you get your dns records?

you can type whatever you want in there, as long as it points to actual servers. @ just means “the top domain in this zone.”

Yeah but where can I get the information itself for my DNS

Like this:

@   IN A
@   IN AAAA 2604:a880:800:c1::18d:4001
www IN A
www IN AAAA 2604:a880:800:c1::18d:4001

I mean you got it from somewhere.

I copied it from your own posts. You can also get it from the dns servers using dig or nslookup.

No, I didn’t post that.

You did, just not in that format :wink:

Ahh I see dig or dnslookup! Man you are too good!