No valid IP addresses found for <myDomain>

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: coderjobmarket.com

I ran this command: sudo certbot --nginx -d coderjobmarket.com -d www.coderjobmarket.com

It produced this output:
“”"
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for coderjobmarket.com
http-01 challenge for www.coderjobmarket.com
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. www.coderjobmarket.com (http-01): urn:ietf:params:acme:error:dns :: No valid IP addresses found for www.coderjobmarket.com

IMPORTANT NOTES:

My web server is (include version): nginx/1.14.0 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 18.04.4

My hosting provider, if applicable, is: DigitalOcean

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

Other notes: My server is up and running with http: http://coderjobmarket.com/.

I read 5 threads that came up in the “Your topic is similar to…” box. My IP address is NOT within a private range as was the problem for one poster. One suggested that “certbot --nginx should be all you need to know” and the output for me of that command was:
“”"
certbot --nginx
The following error was encountered:
[Errno 13] Permission denied: ‘/var/log/letsencrypt/.certbot.lock’
Either run as root, or set --config-dir, --work-dir, and --logs-dir to writeable paths.
“”"

I don’t know if that’s helpful.

Here is a screenshot of my DNS records. I updated the CNAME record about 30 min ago. https://imgur.com/a/EUHrQcz

Anyone have a guess what my problem is? Will be checking the thread regularly for the next 2-3 hrs or so, then I have to leave for work.

1 Like

How long ago did you last make an attempt? That domain doesn’t generate that error for me, when I try.

1 Like

Hey what do you know, it worked. Weird. I don’t know what I changed by waiting. Thanks for your help!