net::ERR_CERT_COMMON_NAME_INVALID


#1

Having an issue renewing a certificate. I think it’s messed up due to me uninstalling Let’s Encrypt as I couldn’t renew the certificate. I then tried to remove the certificate but it wouldn’t remove it with an error saying I can’t remove it as a site is using it. I then reinstalled Let’s Encrypt, tried to renew and it successfully renewed but I have an error on the page:

Your connection is not private

Attackers might be trying to steal your information from [Redacted domain name].co.uk (for example, passwords, messages, or credit cards). NET::ERR_CERT_COMMON_NAME_INVALID

  1. [Redacted domain name].co.uk
  2. I’m on Windows Plesk so I’m trying to renew via the GUI
  3. N/A
  4. Windows Server 2012 R2 running Plesk Onyx Version 17.0.17 Update #11
  5. Dedicated server via Fasthosts

#2

Ok strange but I’ve worked out a fix.

  1. Renew the certificate
  2. Go to Hosting Settings for particular domain
  3. Under security change SSL certificate to default certificate, save
  4. Repeat above but change back to Let’s Encrypt

I’ve repeated that process for multiple domains with success.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.