My website is still not going to HTTPS or Secure after a successful installation

#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www.beginnertrade.com,www.addictionssigns.com, www.seinify.com

I ran this command:sslforfree

It produced this output: My website is still not going to HTTPS or Secure after a successful installation

My web server is (include version): Apache

The operating system my web server runs on is (include version): Linux

My hosting provider, if applicable, is: godaddy

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): None of them, I just followed instructions from sslforfree.com

#2

Hi @Hoosemon

what control panel do you use?

Is there a certificate upload and install form?

#3

PS: Checked your first domain there is a different certificate ( https://check-your-website.server-daten.de/?q=beginnertrade.com ).

CN=*.prod.ams1.secureserver.net, OU=Domain Control Validated
	03.04.2018
	03.04.2020
expires in 374 days	
*.prod.ams1.secureserver.net, prod.ams1.secureserver.net - 2 entries

So the name doesn’t match.

And you have one wrong TXT entry:

TXT - Entries

Domainname TXT Entry Status ∑ Queries ∑ Timeout
beginnertrade.com v=spf1 a mx ptr include:secureserver.net ~all ok 1 0
www.beginnertrade.com v=spf1 a mx ptr include:secureserver.net ~all ok 1 0
_acme-challenge.beginnertrade.com f7vIfapNGxNaDItq1Z236JaN5Z3axjqxVjG0v_au-6A looks good 1 0
_acme-challenge.www.beginnertrade.com 7H2hnllq5N89iw2hb1do91_TIGKRtq9dGLKfz1OneyM looks good 1 0
_acme-challenge.beginnertrade.com.beginnertrade.com f7vIfapNGxNaDItq1Z236JaN5Z3axjqxVjG0v_au-6A perhaps wrong 1 0

The last entry is wrong.

If you use a control panel, your domain name is added.

So create only a new entry with

_acme-challenge

as name.

1 Like
SSL installation on multiple websites
#4

Hi JuergenAuer
I am using godaddy cpnal and there is an install form

#5

[Should read the complete output]

You don’t have a new certificate. But there are a lot of Letsencrypt certificates:

Last Certificates - Certificate Transparency Log Check (BETA)

CRT-Id Issuer not before not after Domain names LE-Duplicate next LE
1194252927 CN=Let’s Encrypt Authority X3, O=Let’s Encrypt, C=US 2019-02-11 12:24:36 2019-05-12 11:24:36 beginnertrade.com, www.beginnertrade.com
864638443 CN=Let’s Encrypt Authority X3, O=Let’s Encrypt, C=US 2018-10-15 14:25:15 2019-01-13 15:25:15 beginnertrade.com, www.beginnertrade.com
840524551 CN=Let’s Encrypt Authority X3, O=Let’s Encrypt, C=US 2018-10-09 09:58:32 2019-01-07 10:58:32 beginnertrade.com, www.beginnertrade.com
836853662 CN=Let’s Encrypt Authority X3, O=Let’s Encrypt, C=US 2018-10-08 15:08:39 2019-01-06 16:08:39 beginnertrade.com, www.beginnertrade.com
825444092 //certs.godaddy.com/repository/, CN=Go Daddy Secure Certificate Authority - G2 2018-10-02 10:18:25 2020-10-02 10:18:25 addictionssigns.com, beginnertrade.com, biblenutrient.com, Domain Control Validated, newtechnol.com, seinify.com, www.newtechnol.com

Three created 2018-10, one 2019-02-11.

Is this the certificate you want to install? There is no newer certificate logged.

#6

I just want my websites to be secure so I don’t mind about any certificate.
I just realise my former developer used a different procedure than the one I am using now.
So I am using the sslforfree.com procedure and not the install form

#7

Hi JuergenAuer
There is an install form from Godaddy cpnal but I didn’t use it

I think my former delevopper used. I am using the sslforfree procedure

Can you advise me on how to get it from the installation form to the sslfofree please

Regards

#8

You have to use both.

First sslforfree instead of an own ACME-client to create a certificate.

Then the upload form to install the certificate.

But if you create a new certificate, it must be visible via CT-Log. There is no new certificate -> the certificate creation didn’t work.

Isn’t there an integrated solution in your cPanel? Theck that first.

#9

What is CT-Log and integrated solution?

#10

Most new certificates are logged in Certificate transparency logs. There are search engines to check that.

https://transparencyreport.google.com/https/certificates

https://crt.sh/

The newest certificate - 2019-02-11. So you don’t have created a newer certificate via sslforfree.

There is a cPanel addin, so it’s enough that you activate that. But it’s possible that your hoster didn’t install that. If it is installed, you should use it. But then it may be impossible to use an external tool like sslforfree.

#11

Hi JuergenAuer
Thank you for your help but I think I need to start reinstalling SSL from scratch in order for me to really understand what I am doing

#12

I restart from scratch with sslforfree and I am receiving the following screenshot


which doesn’t allow me to move on.
The above screenshot it is received when I wanted to verify the upload downloaded file which was not successful.
Can you advise me about what to do please.
Regards

#13

Create an exception - Advanced.

Or use my online tool with the complete url (without https://), then you can check the url.

#14

Hi there
How the integrated solution looks like?

#15

You have root access. Then you can use your own client, not Sslforfree.

Start there:

Then select a client - perhaps Certbot:

#16

The only way to install SSL with Godaddy it is manually nothing work apart from that.
I have been reading that on this site a while.

#17

If you have root access, you can do what you want.

Root access -> own client.
Shared hosting -> cPanel / Plesk or hoster support is required.

#18

I have got root access but I don’t really get the meaning << hoster support >> if you can bread it down for me, please
Regards

#19

Could you send me any video tutorial link which can assist me in relation to the issue, please?
Regards

#20

The hoster support is required if you have a shared hosting. So the hoster manages the webserver and the vHosts.

But if you are able to manage your own Apache and own vHosts (= if you have enough rights), then the hoster isn’t relevant.

So Godaddy may not support Letsencrypt certificates if you have a shared hosting. But with an own vServer or Server - it’s not relevant.

I’ve never checked a video.

to select the correct installation (or use certbot-auto)

then