Limits problems

Dear letsencrypt community,
we are trying to set up the Google Cloud with the SSL but we had quite a few problems and now we are have the ‘limit’ error: An unexpected error occurred:There were too many
requests of a given type :: Error creating new cert :: too many certificates already issued for exact set of domains…

This is totally our fault - well we have been following tutorials which didn’t work and always forced us to start again and we didn’t know about the limits. We didn’t make many request to abuse your services, we just tried to find the way to fix the problem and when we run out of options we started again.

Please, is there any chance we can lift the limit? We are running community website and already 3days offline and as you can imagine we have to be back online ASAP.
Here is our link…
Any suggestion would be great.
Thank you so much
Thank you very much

PS: by checking the I can see we had 5 certs in last 5 days… the limit is 10, isn’t it?

For this error, you can simply add another subdomain to change the certificate. However, if you still have any of the private keys from the first 5, you can just use one of those. Do bear in mind that if you go with the first option (add a subdomain to change the certificate), you’ll still need to watch out for the “certificates per registered domain” limit of 20/week.

In the future, I’d recommend using the staging server to avoid these issues until you have a working process. The rate limits there are much higher to allow for testing.

1 Like

The limit is 5 identical certificates per 7 days, or 20 certificates per registered domain per 7 days.

1 Like

Thank you for your kind reply @jared.m
OMG! Looks like we really messed up BIG TIME!
Please, is there any letsencrypt alternative? We can’t have our site offline for another 7days :(((
We used this tutorial… it’s probably great but it has the ssl renew test - so, this is probably where everything added up :((
Really lost what to do next :((

@Janz, you don’t have to wait for 7 days.

The first certificate that affected your current limit was issued on February 8, so the next permitted issuance of an identical certificate would be on February 15 (Thursday).

If you can’t wait that long, @jared.m has already suggested a workaround: if you add another subdomain to the certificate request, it will no longer be “identical” and this particular limit will no longer prevent its issuance (even right this minute). For example, you could request a certificate for,, and (as long as the last name already exists in DNS and is configured on your servers in the same way as the first two). This certificate would not have identical coverage to your existing certificates, and therefore its issuance would not be prevented by the identical certificates rate limit.

Thank you for the reply @schoen much appreciated.
I tried the ‘giraffe’ example by using ‘o’ and I got the 'Connection refused/

I tried to solve it and yet again:
./certbot-auto certonly --webroot -w /var/www/html/ -d -d -d
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
An unexpected error occurred:
There were too many requests of a given type :: Error creating new authz :: too many failed authorizations recently: see https://letsencrypt.


Hi @Janz,

Well, in order to use --webroot you have to have an existing webserver listening on port 80, which apparently your server doesn't have at the moment.

This particular limit only lasts for an hour rather than for a week.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.