"letsencrypt: command not found" trying to renew a cert


#1

Hi, I am a letsencrypt newbie & taking over from another developer, so forgive me if this is an easy question!

I am trying to renew a certificate for our domain, and when I run the following command:

root@bt-node:/etc/letsencrypt# letsencrypt renew --dry-run

I get the following error:

letsencrypt: command not found

I look at this and then tried

root@bt-node:/etc/letsencrypt# ./letsecrypt-auto renew --dry-run

but then I get the error

-bash: ./letsecrypt-auto: No such file or directory

I would really appreciate if someone could tell me where I am going wrong! Is there any other info I can supply to help?

Thanks


#2

If your predecessor used the git installation of letsencrypt, you’ll have to run the ./letsencrypt-auto command from the directory to which he cloned the repository.

I’d check the home directory. You might also find some clues if you search his ~/.bash_history file for a git clone line. Alternatively, I suppose you could also just reinstall the client in another directory - I haven’t done that before, but I can’t think of a reason why that wouldn’t work right now.


#3

Thanks for the reply. When I run the following command

find / -name letsencrypt

I get the following options:

/etc/letsencrypt
/var/lib/letsencrypt
/var/log/letsencrypt
/root/.local/share/letsencrypt
/root/.local/share/letsencrypt/lib/python2.7/site-packages/letsencrypt
/root/.local/share/letsencrypt/bin/letsencrypt
/root/test/letsencrypt
/root/test/letsencrypt/letsencrypt

Is it just a matter of going through all of those folders and trying, or can you see which one it might be off the top of your head?

Thanks


#4

Probably one of the last two. It’s the one with a file called letsencrypt-auto. :wink:


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.