Letsencrypt renewal help


#1

Please fill out the fields below so we can help you better.

My domain is: files.achhospitalist.com

I ran this command: letsencrypt renew, ./letsencrypt renew, certbot renew, ./certbot renew ./letsencrypt-auto, ./letsencrypt-auto renew, ./certbot-auto renew

It produced this output:command not found

My operating system is (include version): ubuntu 14.04.04

My web server is (include version): Apache 2

My hosting provider, if applicable, is: self hosted

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no. SSH

So I have a bit of a problem. I cannot get the certificate to update so it does not expire in three days. It is really frustrating because I have done it in the past, thought it was very simple but now after spending about 4 hours trying what I thought was the way to update the cert with the commands listed above I cannot update it. I believe I am using letsencrypt and not certbot as the only entries I have when I use “locate certbot” shows up under /etc/letsencrypt/csr but if I do “locate letsencrypt” it shows up /etc/letsencrypt/many sub directories and /var/lib/letsencrypt/many sub directories.


#2

Well, it should also provide you with some kind of script/application! I’m sure you didn’t de-install it? :stuck_out_tongue:

Perhaps you could post that output of locate? Might want to run a updatedb first.


#3

Thanks for taking a look Osiris. No, I didn’t uninstall anything. This server has pretty much been bulletproof with me just doing updates over the last year. Renewed the cert 3 times and all was well, just didn’t remember the exact syntax but thought I knew it until this time. Maybe one of the updates buggered it up? Here is a screenshot of the locate command after running updatedb:


#4

It really looks like the program is no longer installed on your system. However, one possibility is that you were logged in as root when you installed and ran it in the past, and that you are currently not root. (You might have become root by entering su or sudo -s or using PuTTY to log in as root directly with a different password.) It looks to me like the locate command is not showing you files that you don’t have permission to view with ls (which has been the default behavior for a couple of decades because it’s not supposed to give away the existence of files in a way that bypasses their permissions).

So, it’s possible that you have certbot-auto installed in /root and just can’t see it without sudo or something. You could try repeating the command with sudo locate letsencrypt and sudo locate certbot to check this hypothesis.


#5

Schoen you are a genius! When I did sudo locate it showed me where it is (/root/certbot-auto) but I can’t figure out how to run it now? I don’t think I have a “root” password because I tried everything it could be when I do “su”. Can I do something like sudo certbot-auto renew /root/ ???

EDIT
sudo /root/certbot-auto renew from SSH did it. Thank you Schoen!


#6

Great!

If you want to learn about cron and crontab, you can probably also set it up so that the renewal is attempted automatically, without your having to log in and run this command yourself. (We meant for certbot renew to be used this way, and lots of people have succeeded with it and are getting their certificates renewed without human intervention.)

This may lead to learning about several other Unix system administration tasks and tools along the way. :slight_smile:


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.