Bash: ./letsencrypt-auto: No such file or directory

domain: https://thebullfx.com
I cd to my directory for letsencrypt because I’ll be renewing certificate for today when suddenly

root@ip-xxx-xx-xx-xxx:/etc/letsencrypt# ./letsencrypt-auto renew --force-renewal
bash: ./letsencrypt-auto: No such file or directory
root@ip-xxx-xx-xx-xxx:/etc/letsencrypt#

I remember I used to renew it before wayback around november but now all of a sudden this what happened. Please help.

I ran this command:
./letsencrypt-auto renew --force-renewal

It produced this output:
bash: ./letsencrypt-auto: No such file or directory

My web server is (include version):
apache

The operating system my web server runs on is (include version):
ubuntu 14 trusty

My hosting provider, if applicable, is:
AWS

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no

letsencrypt-auto is a really old name for the client, and I’m not sure that /etc/letsencrypt is where it installs to. Could you show us the output of an ls -l on that directory? i’m guessing either you updated and now have certbot-auto, or it’s installed in another directory.

Hello @jared.m

Yes I think it’s now updated when I tried to issue a certbot renew

here is the output, but I do not have any idea what “Cert not yet due for renewal” is all about.

root@ip-xxx-xx-xx-xxx:/etc/letsencrypt# certbot renew
Saving debug log to /var/log/letsencrypt/letsencrypt.log


Processing /etc/letsencrypt/renewal/thebullfx.com.conf

Cert not yet due for renewal

The following certs are not due for renewal yet:
/etc/letsencrypt/live/thebullfx.com/fullchain.pem (skipped)
No renewals were attempted.
root@ip-xxx-xx-xx-xxx:/etc/letsencrypt# ls
accounts archive csr keys live options-ssl-apache.conf renewal
root@ip-xxx-xx-xx-xxx:/etc/letsencrypt#

Also I don’t have any idea how it changed to certbot. because what I normally do when renewing cert is just issuing the command

./letsencrypt-auto renew

thank you very much for the reply @jared.m

Because you use the ./ meaning “in this directory”, it matters what directory you are in when you run that command. You could try locate letsencrypt-auto to try to find where your copy is located.

Certbot was renamed from letsencrypt quite some time ago but you probably have two different versions—one from an operating system package and one from the -auto script which you may have installed yourself with wget or some other option (or maybe even git clone, which is questionable advice in some old tutorials).

Your current certificates were issued in November

https://crt.sh/?Identity=%thebullfx.com&iCAID=16418

and following the 30 day renewal default, they’re not due for renewal until later on this week. certbot renew and other forms normally only attempt to renew certificates that are less than 30 days away from expiring.

1 Like

Hello @schoen

Thank you for this reply what you said was very helpful for learners like me. I learned something today sir :slight_smile:

Thank you very much.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.