Lets Encrypt Service Down


#1

The service is having trouble starting.

I have webmin firewall installed

here is the log

2016/03/08 23:43:14 Daemon starting
2016/03/08 23:43:15 Checking for updates …
2016/03/08 23:43:15 Processing renewals
2016/03/09 11:45:16 Processing renewals
2016/03/09 23:43:16 Checking for updates …
2016/03/09 23:43:46 Failed to check for updates Unable to get latest version: G$
2016/03/09 23:49:17 Processing renewals
2016/03/10 00:43:46 Checking for updates …
2016/03/10 00:44:16 Failed to check for updates Unable to get latest version: G$
2016/03/10 01:44:16 Checking for updates …
2016/03/10 01:44:46 Failed to check for updates Unable to get latest version: G$
2016/03/10 01:56:05 Caught signal terminated
2016/03/10 01:56:05 Daemon exiting
2016/03/10 01:58:04 Invalid hostname
2016/03/10 02:08:07 Invalid hostname
2016/03/10 02:13:08 Invalid hostname
2016/03/10 02:18:09 Invalid hostname
2016/03/10 02:19:40 Invalid hostname
2016/03/10 02:24:41 Invalid hostname

and below is the email from cpanel chkservd when it fails to start

Service Name letsencrypt
Service Status failed No entry
Notification The service “letsencrypt” appears to be down.
Service Check Method The system failed to connect to this service’s TCP/IP port.
Reason Unable to connect to port 5959 on 127.0.0.1: Connection refused: Died
Number of Restart Attempts 275
Startup Log No startup log
Memory Information
Used 1.58 GB
Available 6.97 GB
Installed 8 GB
Load Information 0.16 0.05 0.01
Uptime 22 hours, 55 minutes, and 12 seconds
IOStat Information avg-cpu: %user %nice %system %iowait %steal %idle
0.53 0.02 0.07 0.00 0.00 99.38
Device: tps Blk_read/s Blk_wrtn/s Blk_read Blk_wrtn
Top Processes
PID Owner CPU % Memory % Command
30722 root 10.67 0.29 tailwatchd - chkservd - imap check
30777 root 9.76 0.24 /usr/local/cpanel/scripts/restartsrv_dovecot --check --notconfigured-ok
30731 dovecot 0.72 0.02 dovecot/auth
30357 nobody 0.67 0.64 /usr/local/apache/bin/httpd -k start
30366 nobody 0.37 0.68 /usr/local/apache/bin/httpd -k start

The chkservd process attempts to connect to “127.0.0.1:5959” in order to validate that this service is functioning. If you blocked connections with iptables or the “Host Access Control” interface in WHM, this failure may be a false positive.

To resolve this issue, either open the firewall to allow connections as the root user to “127.0.0.1:5959” or disable checks for this service in WHM’s “Service Manager” interface with the “Configure Monitor Settings” link below.


#2

Did you try doing this? You mention that some kind of firewall is enabled.


#3

yes i have webmin firewall the data center installed but not familier with it. csf was causing nothing but problems.


#4

I’m afraid I’m not familiar with webmin firewall. You’re probably better off asking this question in some community dedicated to webmin, as it’s not really related to Let’s Encrypt.

(Unless someone here happens to know how to add that firewall rule, of course :wink:).


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.