Error checking licence status


#1

There was a problem processing your request

Error checking licence status
Get http://127.0.0.1:5959/check-licence: dial tcp 127.0.0.1:5959: getsockopt: connection refused

I am also getting this emailed to me by Cpanel:

The service “letsencrypt-cpanel” appears to be down.
Server servername (edited out for security)
Primary IP Address xxx.xxx.xxx (edited out for security)
Service Name letsencrypt-cpanel
Service Status failed :no_entry:
Notification The service “letsencrypt-cpanel” appears to be down.
Service Check Method The system failed to connect to this service’s TCP/IP port.
Reason Unable to connect to port 5959 on 127.0.0.1: Connection refused: Died
Number of Restart Attempts 24
Startup Log Sep 23 03:29:32 server1.servername.com systemd[1]: Unit letsencrypt-cpanel.service entered failed state.
Sep 23 03:29:32 server1.servername.com systemd[1]: letsencrypt-cpanel.service failed.
Memory Information
Used 1.01 GB
Available 30.36 GB
Installed 31.38 GB
Load Information 0.22 0.07 0.06
Uptime 2 hours, 21 minutes, and 48 seconds
IOStat Information avg-cpu: %user %nice %system %iowait %steal %idle
0.24 0.16 0.11 0.86 0.00 98.62
Device: tps kB_read/s kB_wrtn/s kB_read kB_wrtn
sdb 7.98 51.80 422.24 440682 3592200
sda 19.03 399.14 422.24 3395666 3592200
md3 8.26 226.30 148.01 1925205 1259180
md2 77.69 224.31 270.64 1908325 2302484
Top Processes
PID Owner CPU % Memory % Command
19619 root 5.17 0.07 /usr/local/cpanel/scripts/restartsrv_ipaliases --check --notconfigured-ok
19558 root 5.00 0.31 spamd child
1129 root 0.56 0.32 /usr/local/cpanel/3rdparty/perl/522/bin/perl -T -w /usr/local/cpanel/3rdparty/bin/spamd --allowed-ips=127.0.0.1,::1 --max-children=5 --pidfile=/var/run/spamd.pid --listen=5 --listen=6
19501 root 0.55 0.10 tailwatchd - chkservd - ipaliases check
2137 mysql 0.13 0.49 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib64/mysql/plugin --user=mysql --log-error=/var/lib/mysql/server1.servername.com.err --open-files-limit=10000 --pid-file=/var/lib/mysql/server1.servername.com.pid
The chkservd process attempts to connect to “127.0.0.1:5959” in order to validate that this service is functioning. If you blocked connections with iptables or the “Host Access Control” interface in WHM, this failure may be a false positive.

To resolve this issue, either open the firewall to allow connections as the root user to “127.0.0.1:5959” or disable checks for this service in WHM’s “Service Manager” interface with the “Configure Monitor Settings” link below.


#2

this is a core network connectivity issue with your provider.

No TLS errors so best to check with your provider on how to enable this

re_**solve this issue, either open the firewall to allow connections as **
**the root user to “127.0.0.1:5959” or disable checks for this service in **
**WHM’s “Service Manager” interface with the “Configure Monitor Settings” **
link below.


#3

Hi Andrew. Thank you for your reply. I have allowed port 5656 in my firewall. But still the same error. I have also tried disabling checks in Config Monitor Settings, but still the same error. It is my own dedicated server so not support.


#4

You might have more luck with this question on the cPanel support forum as this looks more like a cPanel issue. Not to say that it’s not possible someone here has run into this issue before and knows how to solve this. :wink:


#5

Thank you all for your feedback. I used a plugin “lts encrypt for cpanel”, the error was casued as the license file was not matching my new server name as I had renamed it. I have now updated the license and in the process of re-installing. It is strange how it was flagged as a port issue by cPanel though.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.