LetsEncrypt-cPanel Service is Down


#1

Please fill out the fields below so we can help you better.

My domain is: sausagdogcentral

I ran this command:

It produced this output: http://prntscr.com/fum76p

My web server is (include version): cPanel/WHM 64.0 build 30

The operating system my web server runs on is (include version): CentOS 6.9 final

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): cPanel/WHM 64.0 build 30


#2

That looks like something specific to that cPanel plugin. If it’s being supplied by your hosting company, you should try contacting them. If not, try contacting the developers of that extension for support. Alternately, if you have the experience, you can try reading the log file mentioned in the screenshot and see if that provides more information for you to fix the issue.


#3

Hi,

Its been working fine all along but suddenly few days ago this error occurred and even after my uninstalling and reinstalling its not going away.
This is another screenshot please see: http://prntscr.com/fum8id
In it it says that unable to connect to port 5959 and i dont know how it was working all fine before and suddenly it stated connection to port issue. I have opened this port specifically after this error but still no luck and the plugin is still down.

Any other idea please?

Thanks


#4

My hosting company is https://webshosting.net and no they did not supplied it, i got it and installed it from this websites:
https://documentation.cpanel.net/display/CKB/The+Let's+Encrypt+Plugin
https://letsencrypt-for-cpanel.com/docs/for-admins/installation/


#5

Yeah, like @motoko said, that’s definitely related to the plugin and not on the Let’s Encrypt side. I’d reach out to the developers of that plugin for assistance as we don’t have any information on how it operates. Contact form is here. (Also maybe run the command on that page.)


#6

Thanks for the response jared. Can you please tell me if there is anyway i could use LetsEncrypt with for my cpanel domains to install SSL on my domains and addon-domains without using that letsencrypt plugin for cpanel?

Thanks


#7

hi @umar89

You will need to do some digging if cPanel allows install of 3rd Party certificates (I believe they do) and then choose a client to obtain certificates

If this seems confusing search these forums and google as this question has been asked many times before

Andrei


#8

Thank you for your help. :slight_smile:


#9

I’d recommend ZeroSSL. It’s an online service that interfaces with Let’s Encrypt to issue certificates through your browser. Head over there and pick the ‘free SSL certificate’ option (or something named substantially similar.) The first time, it’ll generate a LE account key, CSR, and private key for you. You’ll also get the cert, of course, after authorization. Save all these, you can paste the account key and CSR in during renewal to make things easier next time. The other two you need to put into the cpanel certificate manager.


#10

Just remember that you will then need to repeat this process at least every 90 days because of the certificate expiry.


#11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.