I downloaded the client via git clone and started the ‘letsencrypt-auto’.
apt-get starts updating and ends relativly soona fter this error message.
Reading package lists... Done Building dependency tree Reading state information... Done gcc is already the newest version. git is already the newest version. libssl-dev is already the newest version. python is already the newest version. ca-certificates is already the newest version. You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: libaugeas0 : Depends: augeas-lenses but it is not going to be installed libssl-dev : Depends: libssl1.0.0 (= 1.0.1e-2+deb7u17) but 1.0.2c-1 is to be installed Depends: zlib1g-dev but it is not going to be installed libtinfo5 : Breaks: dialog (< 1.2-20130523) but 1.1-20120215-2 is to be installed python-dev : Depends: python2.7-dev (>= 2.7.3-1~) but it is not going to be installed python-virtualenv : Depends: python-pkg-resources but it is not going to be installed Depends: python-setuptools but it is not going to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution). Failed to install a working "virtualenv" command, exiting
I tried ‘apt-get -f install’ and ‘dpkg --configure -a’ but nothing helped.
I’m running debian 7.8 wheezy on my machine.