Installation problem 'unmet dependencies' debian7


#1

I downloaded the client via git clone and started the ‘letsencrypt-auto’.
apt-get starts updating and ends relativly soona fter this error message.

Reading package lists... Done
Building dependency tree
Reading state information... Done
gcc is already the newest version.
git is already the newest version.
libssl-dev is already the newest version.
python is already the newest version.
ca-certificates is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libaugeas0 : Depends: augeas-lenses but it is not going to be installed
 libssl-dev : Depends: libssl1.0.0 (= 1.0.1e-2+deb7u17) but 1.0.2c-1 is to be installed
              Depends: zlib1g-dev but it is not going to be installed
 libtinfo5 : Breaks: dialog (< 1.2-20130523) but 1.1-20120215-2 is to be installed
 python-dev : Depends: python2.7-dev (>= 2.7.3-1~) but it is not going to be installed
 python-virtualenv : Depends: python-pkg-resources but it is not going to be installed
                     Depends: python-setuptools but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Failed to install a working "virtualenv" command, exiting

I tried ‘apt-get -f install’ and ‘dpkg --configure -a’ but nothing helped.
I’m running debian 7.8 wheezy on my machine.

Any ideas?


#2

I am also having a similar issue, but these are the errors I get at the end of the requests.

Reading package lists... Done E: No packages found Reading package lists... Done Building dependency tree Reading state information... Done libaugeas0 is already the newest version. ca-certificates is already the newest version. dialog is already the newest version. gcc is already the newest version. git is already the newest version. libffi-dev is already the newest version. libssl-dev is already the newest version. python is already the newest version. python-dev is already the newest version. python-virtualenv is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. Creating virtual environment... Cannot locate wrapped file

Any help would be greatly appreciated. Thanks!


#3

Ok, i couldn’t solve my problem the “normal” way.
I updated to debian8 with a new and clean system and now everything works just fine.