Unable to install on Ubuntu 14.04


#1

Errors installing packages:

Building dependency tree
Reading state information… Done
dialog is already the newest version.
gcc is already the newest version.
python is already the newest version.
ca-certificates is already the newest version.
git is already the newest version.
libssl-dev is already the newest version.
libssl-dev set to manually installed.
The following extra packages will be installed:
augeas-lenses libpython-dev libpython2.7-dev python-chardet-whl python-colorama-whl python-distlib-whl python-html5lib-whl
python-pip-whl python-requests-whl python-setuptools-whl python-six-whl python-urllib3-whl python2.7-dev python3-virtualenv
Suggested packages:
augeas-doc augeas-tools
The following NEW packages will be installed:
augeas-lenses libaugeas0 libffi-dev libpython-dev libpython2.7-dev python-chardet-whl python-colorama-whl python-dev
python-distlib-whl python-html5lib-whl python-pip-whl python-requests-whl python-setuptools-whl python-six-whl
python-urllib3-whl python-virtualenv python2.7-dev python3-virtualenv virtualenv
0 upgraded, 19 newly installed, 0 to remove and 5 not upgraded.
Need to get 34.2 MB of archives.
After this operation, 49.5 MB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
libpython2.7-dev augeas-lenses libaugeas0 libpython-dev python-chardet-whl python-colorama-whl python2.7-dev python-dev
python-distlib-whl python-html5lib-whl python-six-whl python-urllib3-whl python-requests-whl python-setuptools-whl
python-pip-whl python-virtualenv python3-virtualenv virtualenv libffi-dev
E: There are problems and -y was used without --force-yes
Failed to install a working “virtualenv” command, exiting


#2

Install worked fine for me (though, something else went wrong) using Ubuntu 14.04. Have you tried installing these packages manually?

apt-get install --force-yes libpython2.7-dev augeas-lenses libaugeas0 libpython-dev python-chardet-whl python colorama-whl python2.7-dev python-dev python-distlib-whl python-html5lib-whl python-six-whl python-urllib3-whl python-requests-whl python-setuptools-whl python-pip-whl python-virtualenv python3-virtualenv virtualenv libffi-dev


#3

Your system is up to date, right?


#4

in what sense do you mean “up to date”? it’s running 14.04 not 15.0whatever so in that sense, no, but i can’t upgrade for other reasons.


#5

yeah those fail as well. i get tons of 404 errors from apt-get upgrade. looks like that’s its own separate problem.


#6

Could you try apt-get update to update your server’s package listings.


#7

… and a apt-get upgrade after that


#8

Yeah, that will install the latest versions of all currently installed packages.


#9

apt-get update is what i meant, not upgrade, sorry. and another error - i’d forgotten that this newer box came with 14.10 on it, not 14.04. 14.10 isn’t a long-term release, that seems to be the problem. in any case this isn’t a letsencrypt problem.

for anybody else running into this: i’m working with this solution to the 14.10 problem

it won’t let me post that as a link


#10

Eh, that gave me this error.

E: Unable to locate package colorama-whl
E: Unable to locate package python3-virtualenv
E: Unable to locate package virtualenv

Running Ubuntu 14.04.3 LTS (GNU/Linux 3.13.0-65-generic x86_64)


#11

The rest of the packages are already installed and newest version.


#12

You need the universe repo.


#13

No clue what that means. Is my system limited in some way? ubuntu-server


#14

Not really, you just need to run;

sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu $(lsb_release -sc) universe"
(Source; http://askubuntu.com/questions/78613/how-do-i-enable-the-universe-repository-from-the-command-line)

Remember to run apt-get update && apt-get upgrade after just to be 100% sure :smile:


#15

I already have that.


#16

I don’t think those are the correct packages for Ubuntu 14.04. The OP was using 14.10 which includes different packages for virtualenv (for example, python3-virtualenv is python-virtualenv there). ./letsencrypt-auto should install the correct packages for Ubuntu 14.04 automatically If you want to do it manually, look at this file:
https://github.com/letsencrypt/letsencrypt/blob/master/bootstrap/_deb_common.sh


#17

Yeah, it should.
Except mine fails with:

ImportError: No module named _struct


#18

Take a look at the solutions posted in this StackExchange questions, maybe one of them works for you.


#19

Nope. Already checked those suggestions before posting here.
Reinstalled several times. Takes a few seconds.

Don’t know any other Python things that fail. Only Letsencrypt.


#20

Running LE as root seems to a particularly bad idea, for me.
https://pastee.org/277p4

Instead following the guide on how to install the dev version worked on my secondary account.
https://letsencrypt.readthedocs.org/en/latest/contributing.html

After that I can run the .local/share/letsencrypt/bin/letsencrypt file just fine.

Running the le-auto script I always get that complaint initially.
E: No packages found

Seems things still work, even if it’s missing something.

Do note, that the install on my regular account works just fine. It’s just that I wanted to run LE in cron and then setup a specific account for it. On that account le-auto refused to work, until I stumbled on the dev instructions.