Install error on Ubuntu natty


#1

I have this error, and no clue how i can solve it:

Reading package lists… Done
No LSB modules are available.
No LSB modules are available.
No libaugeas0 version is available that’s new enough to run the
Let’s Encrypt apache plugin…
Reading package lists… Done
Building dependency tree
Reading state information… Done
augeas-lenses is already the newest version.
gcc is already the newest version.
libaugeas0 is already the newest version.
libffi-dev is already the newest version.
dialog is already the newest version.
python-virtualenv is already the newest version.
ca-certificates is already the newest version.
libssl-dev is already the newest version.
python is already the newest version.
python-dev is already the newest version.
The following packages were automatically installed and are no longer required:
libgsasl7 libmailutils2 guile-1.8-libs libntlm0
Use ‘apt-get autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 79 not upgraded.
Checking for new version…
Creating virtual environment…
Installing Python packages…
Had a problem while installing Python packages:
/root/.local/share/letsencrypt/lib/python2.7/site-packages/pip/pep425tags.py:28: RuntimeWarning: invalid Python installation: unable to open /root/.local/share/letsencrypt/local/lib/python2.7/config/Makefile (No such file or directory)
warnings.warn("{0}".format(e), RuntimeWarning)
Collecting argparse==1.4.0 (from -r /tmp/tmp.57vb8F4Sdi/letsencrypt-auto-requirements.txt (line 5))
/root/.local/share/letsencrypt/lib/python2.7/site-packages/pip/vendor/requests/packages/urllib3/util/ssl.py:315: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning.
SNIMissingWarning
/root/.local/share/letsencrypt/lib/python2.7/site-packages/pip/vendor/requests/packages/urllib3/util/ssl.py:120: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https–>//urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
InsecurePlatformWarning
Downloading argparse-1.4.0-py2.py3-none-any.whl
Collecting pycparser==2.14 (from -r /tmp/tmp.57vb8F4Sdi/letsencrypt-auto-requirements.txt (line 11))
Downloading pycparser-2.14.tar.gz (223kB)
Collecting cffi==1.4.2 (from -r /tmp/tmp.57vb8F4Sdi/letsencrypt-auto-requirements.txt (line 14))
Downloading cffi-1.4.2.tar.gz (365kB)
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File “”, line 1, in
File “/tmp/pip-build-xdnan8/cffi/setup.py”, line 111, in
ask_supports_thread()
File “/tmp/pip-build-xdnan8/cffi/setup.py”, line 59, in ask_supports_thread
ok = config.try_compile(’__thread int some_threadlocal_variable_42;’)
File “/usr/lib/python2.7/distutils/command/config.py”, line 230, in try_compile
self._check_compiler()
File “/usr/lib/python2.7/distutils/command/config.py”, line 103, in _check_compiler
customize_compiler(self.compiler)
File “/usr/lib/python2.7/distutils/ccompiler.py”, line 33, in customize_compiler
’ARFLAGS’)
File “/usr/lib/python2.7/sysconfig.py”, line 457, in get_config_vars
_init_posix(_CONFIG_VARS)
File “/usr/lib/python2.7/sysconfig.py”, line 310, in _init_posix
raise IOError(msg)
IOError: invalid Python installation: unable to open /root/.local/share/letsencrypt/local/lib/python2.7/config/Makefile (No such file or directory)

----------------------------------------

Command “python setup.py egg_info” failed with error code 1 in /tmp/pip-build-xdnan8/cffi
/root/.local/share/letsencrypt/lib/python2.7/site-packages/pip/vendor/requests/packages/urllib3/util/ssl.py:120: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https:–>/urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
InsecurePlatformWarning
You are using pip version 8.0.3, however version 8.1.2 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.

Regards,

Marc


#2

Natty stopped receiving updates almost 4 years ago, so it’s not really a platform the client is tested with.

If you’re unable to switch to a more recent Ubuntu release for some reason, you should probably take a look at the list of other clients. Some of them (like the bash clients) have little to no dependencies and should work in your environment.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.