Install fails on Debian 8.5


Please fill out the fields below so we can help you better.

My domain is:

I ran this command: letsencrypt-auto

It produced this output: In --require-hashes mode, all requirements must have their versions pinned with ==. These do not:
psutil>=2.2.1 from (from certbot==0.8.1->-r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 165))
You are using pip version 8.0.3, however version 8.1.2 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.

My operating system is (include version): Debian 8.5

My web server is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


I wanted to renew my certs. So I thought to get the latest and made a $ git pull -v.

Afterwards I switched into the letsencrypt folder and invoked $ ./letsencrypt-auto.

This fails with

# ./letsencrypt-auto Bootstrapping dependencies for Debian-based OSes... Ign jessie InRelease Ign InRelease Hit jessie-updates InRelease Hit Release.gpg Hit jessie Release.gpg Hit Release Hit jessie Release Hit jessie-updates/main Sources Hit jessie/updates InRelease Hit Packages Get:1 jessie-updates/main amd64 Packages/DiffIndex [5440 B] Get:2 jessie-updates/main Translation-en/DiffIndex [2704 B] Hit jessie/main Sources Hit jessie/main amd64 Packages Hit jessie/main Translation-en Hit jessie/updates/main Sources Hit jessie/updates/main amd64 Packages Hit jessie/updates/main Translation-en Ign Translation-en Fetched 8144 B in 4s (1843 B/s) Reading package lists... Done Reading package lists... Done Building dependency tree Reading state information... Done augeas-lenses is already the newest version. libaugeas0 is already the newest version. ca-certificates is already the newest version. dialog is already the newest version. gcc is already the newest version. libffi-dev is already the newest version. libssl-dev is already the newest version. python is already the newest version. python-dev is already the newest version. python-virtualenv is already the newest version. virtualenv is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. Creating virtual environment... Installing Python packages... Had a problem while installing Python packages: Collecting argparse==1.4.0 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 5)) Downloading argparse-1.4.0-py2.py3-none-any.whl Collecting pycparser==2.14 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 11)) Downloading pycparser-2.14.tar.gz (223kB) Collecting cffi==1.4.2 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 14)) Downloading cffi-1.4.2.tar.gz (365kB) Collecting ConfigArgParse==0.10.0 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 31)) Downloading ConfigArgParse-0.10.0.tar.gz Collecting configobj==5.0.6 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 33)) Downloading configobj-5.0.6.tar.gz Collecting cryptography==1.2.3 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 35)) Downloading cryptography-1.2.3.tar.gz (373kB) Collecting enum34==1.1.2 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 57)) Downloading enum34-1.1.2.tar.gz (46kB) Collecting funcsigs==0.4 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 60)) Downloading funcsigs-0.4-py2.py3-none-any.whl Collecting idna==2.0 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 63)) Downloading idna-2.0-py2.py3-none-any.whl (61kB) Collecting ipaddress==1.0.16 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 66)) Downloading ipaddress-1.0.16-py27-none-any.whl Collecting linecache2==1.0.0 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 69)) Downloading linecache2-1.0.0-py2.py3-none-any.whl Collecting ndg-httpsclient==0.4.0 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 72)) Downloading ndg_httpsclient-0.4.0.tar.gz Collecting ordereddict==1.1 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 74)) Downloading ordereddict-1.1.tar.gz Collecting parsedatetime==2.1 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 76)) Downloading parsedatetime-2.1-py2-none-any.whl Collecting pbr==1.8.1 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 79)) Downloading pbr-1.8.1-py2.py3-none-any.whl (89kB) Collecting pyasn1==0.1.9 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 82)) Downloading pyasn1-0.1.9-py2.py3-none-any.whl Collecting pyOpenSSL==0.15.1 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 94)) Downloading pyOpenSSL-0.15.1-py2.py3-none-any.whl (102kB) Collecting pyRFC3339==1.0 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 97)) Downloading pyRFC3339-1.0-py2.py3-none-any.whl Collecting python-augeas==0.5.0 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 100)) Downloading python-augeas-0.5.0.tar.gz (90kB) Collecting python2-pythondialog==3.3.0 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 102)) Downloading python2-pythondialog-3.3.0.tar.bz2 (1.8MB) Collecting pytz==2015.7 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 105)) Downloading pytz-2015.7-py2.py3-none-any.whl (476kB) Collecting requests==2.9.1 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 119)) Downloading requests-2.9.1-py2.py3-none-any.whl (501kB) Collecting six==1.10.0 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 122)) Downloading six-1.10.0-py2.py3-none-any.whl Collecting traceback2==1.4.0 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 125)) Downloading traceback2-1.4.0-py2.py3-none-any.whl Collecting unittest2==1.1.0 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 128)) Downloading unittest2-1.1.0-py2.py3-none-any.whl (96kB) Collecting zope.component==4.2.2 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 131)) Downloading zope.component-4.2.2.tar.gz (546kB) Collecting zope.event==4.1.0 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 133)) Downloading zope.event-4.1.0.tar.gz (476kB) Collecting zope.interface==4.1.3 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 135)) Downloading zope.interface-4.1.3.tar.gz (141kB) Collecting mock==1.0.1 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 153)) Downloading (861kB) Collecting letsencrypt==0.7.0 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 156)) Downloading letsencrypt-0.7.0-py2-none-any.whl Collecting acme==0.8.1 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 162)) Downloading acme-0.8.1-py2.py3-none-any.whl (91kB) Collecting certbot==0.8.1 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 165)) Downloading certbot-0.8.1-py2-none-any.whl (217kB) Collecting certbot-apache==0.8.1 (from -r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 168)) Downloading certbot_apache-0.8.1-py2-none-any.whl (103kB) Requirement already satisfied (use --upgrade to upgrade): setuptools>=1.0 in /root/.local/share/letsencrypt/lib/python2.7/site-packages (from cryptography==1.2.3->-r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 35)) Collecting psutil>=2.2.1 (from certbot==0.8.1->-r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 165)) In --require-hashes mode, all requirements must have their versions pinned with ==. These do not: psutil>=2.2.1 from (from certbot==0.8.1->-r /tmp/tmp.CsS0J2vPbd/letsencrypt-auto-requirements.txt (line 165)) You are using pip version 8.0.3, however version 8.1.2 is available. You should consider upgrading via the 'pip install --upgrade pip' command.

Also destroying my old installment on ~/.local/share/letsencrypt. =(

I have # lsb_release -a No LSB modules are available. Distributor ID: Debian Description: Debian GNU/Linux 8.5 (jessie) Release: 8.5 Codename: jessie and it is up-to-date.

and plenty of space # df -h Filesystem Size Used Avail Use% Mounted on /dev/sda1 226G 50G 165G 24% / udev 10M 0 10M 0% /dev tmpfs 377M 39M 338M 11% /run tmpfs 941M 0 941M 0% /dev/shm tmpfs 5.0M 4.0K 5.0M 1% /run/lock tmpfs 941M 0 941M 0% /sys/fs/cgroup /dev/sdb1 917G 2.2G 869G 1% /srv/cloud /dev/sdc2 1.8T 125G 1.6T 8% /srv/backup /dev/sdc1 1.8T 273G 1.5T 16% /srv/exports tmpfs 189M 4.0K 189M 1% /run/user/108 tmpfs 189M 0 189M 0% /run/user/1000

Googling about this error lead me to many issues regarding having to less space in /tmp. But this seems not the problem in my case.

I also didn’t had python-pip installed in the first place. So I installed it and run ‘pip install --upgrade pip’ but to no avail.

What should I do?


I believe you’re running into the same problem that’s described in this thread:

@joohoi provided a temporary workaround in that thread. Since you’re on Debian jessie, you could also install the certbot package (which is the new name for the letsencrypt client, all commands should be compatible) from backports via sudo apt-get install python-certbot-apache -t jessie-backports. More details can be found on the certbot homepage.


The problem is now fixed for everybody.


Made a git pull today and everything now works. Thx. =)


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.