Can't install certbot on Debian Jessy (unmet dependencies)


Hi all,

I was using the letsencrypt CLI the past few months to renew my certs without any problems.
I would like now to use the certbot utillity on my Debian 8.5 server. Following the documentation guidelines, when I try installing the certbot package via backports, I get:

>> aptitude install certbot -t jessie-backports
Les NOUVEAUX paquets suivants vont être installés :
certbot python-acme{ab} python-certbot{ab} python-cffi{a} python-chardet{a} python-    configargparse{a} python-configobj{a} python-cryptography{a}
python-dialog{a} python-mock{a} python-ndg-httpsclient{a} python-openssl{a} python-parsedatetime{a} python-ply{a} python-pyasn1{a} python-pycparser{a}
python-pyicu{a} python-requests{a} python-rfc3339{a} python-setuptools{a} python-six{a} python-support{a} python-tz{a} python-urllib3{a}
python-zope.component{a} python-zope.event{a} python-zope.interface{a}
0 paquets mis à jour, 27 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 1 915 ko d'archives. Après dépaquetage, 9 454 ko seront utilisés. 
Les paquets suivants ont des dépendances non satisfaites :
python-acme : Dépend: python-openssl (>= 0.15) mais 0.14-1 doit être installé.
           Dépend: python-cryptography (>= 0.8) mais 0.6.1-1 doit être installé.
           Dépend: python-setuptools (>= 11.3~) mais 5.5.1-1 doit être installé.
python-certbot : Dépend: python-cryptography (>= 0.7) mais 0.6.1-1 doit être installé.
              Dépend: python-psutil (>= 2.2.1) mais il ne sera pas installé.
Les actions suivantes permettront de résoudre ces dépendances :

Conserver les paquets suivants dans leur version actuelle :
1)     certbot [Non installé]
2)     python-acme [Non installé]
3)     python-certbot [Non installé]

Accepter cette solution ? [Y/n/q/?] q

Well, in short, I have unmet dependencies … Of course, an aptitude update has been run before.

Any idea? I need to renew my certificates in the next few days (I’m late, I know, and haven’t make it fully automated … for now!).
Thank you!



Just accept the solution offered (Press Y) - which is to install the missing dependencies (certbot, python-acme, and python-certbot).
The python-psutil problem is due to, um, backporting enthusiasm. You currently have 2.1.1-1, the backports require a minimum of 2.2.1 (which doesn’t exist - but 4.1x does).

Use the offered solution, if it doesn’t pull in python-psutils from backports install it manually. The backports version is greater than the minimum version requirement.

You may want to check afterwards with apt-get -sf install | more (as root), and perhaps read up on basic Debian package management (available in your native language).


The problem is, the proposed solution is not to install the missing dependencies, but to let them in the state they were before, i.e. uninstalled. Other solutions are proposed by unison to solve this dependency issue, but none is viable I think.


Perhaps you can manually first update python-openssl, python-cryptography, python-setuptools and python-psutil?

Because all those deps are viable in Jessie Backports, you’ve just got old versions installed:

Or perhaps your aptitude update isn’t properly working?


Playing with unison to find an alternative way to install the missing dependencies, I found a way to force the installation of the missing python packages available in the backport repository.
Indeed, everything needed is in backport, but unison systematically tried to install the dependencies from the main repository.

Problem solved! Thank you all.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.