Unable to install certbot


#1

Hi there,

since today morning I’m unable to install certbot from the jessie backports-repository.

root@web: ~ # apt-get install -t jessie-backports certbot python-certbot-apache
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 certbot : Depends: python-certbot (= 0.8.0-1~bpo8+2) but it is not going to be installed
 python-certbot-apache : Depends: python-certbot but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Anything wrong with the repository? Is python-certbot removed from backports?

Thanks!


[solved]Trying To Install Certbot on Debian Jessie - Dependency Issues
#2

The problem is that in backports now there is python-acme 0.8.1 which in dependancy info says it break python-certbot < 0.8.1 but the last python-certbot available in backports is 0.8.0-1~bpo8+2.
The new version (0.8.1-2) has been accepted in testing a copule of day ago (see https://packages.qa.debian.org/p/python-certbot.html), I think the mantainer is going to put it also in backports


#3

Thanks!

Is there an easy way to install certbot on a debian jessie-machine right now?


#4

I have to exact same issue now. I will for now follow the manual certbot installation:


#5

I just added the testing-repository to my sources.list:
deb http://ftp2.de.debian.org/debian/ testing main
and installed certbot from there:
apt-get install python-certbot-apache -t testing
I think that’s the better way to do it right now.


#6

@hlieberman can you have a look please?


Installing Certbot on Debian 8 - OS Package Manager Not Installing Certbot
#7

Hello everyone,

This is totally my fault. I normally hold off on uploading any of the packages in case that there is a problem with the later versions, but it slipped my mind this time. Of course, luck would have it that we ran into a bug in one of our dependencies, and I wasn’t able to upload the subsequent python-certbot and python-certbot-apache packages.

I’m working with the dependency maintainers to get this fixed as quickly as possible. I’ll provide more updates this afternoon.


Can not install on Debian Jessie (Backports)
Can not install on Debian Jessie (Backports)
Problem while installing certbot
#8

Hello everyone.

Just spoke again with the dependency maintainer; the package should be fixed this evening. Very sorry for the disruption.


#9

Hello everyone,

I just updated the packages. It may take a couple of hours or so for the packages to make it all the way through to the mirrors, but it should be fixed soon.


DeserializationError
#10

Jep, working again with the backports-repository. Thanks!


Certbot --apache has error on debian
#11

I just tried to install and got the following error:

# apt-get install -t jessie-backports certbot python-certbot-apache
Reading package lists... Done
E: The value 'jessie-backports' is invalid for APT::Default-Release as such a release is not available in the sources

Any thoughts to help troubleshoot?


#12

You should first enable backports, see https://backports.debian.org/Instructions/


#13

@came88 thank you, that did the trick.


#14

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.