Problem while installing certbot


#1

I went to https://certbot.eff.org/#debianjessie-apache and read the install command “sudo apt-get install python-letsencrypt-apache -t jessie-backports”. After i run this command it results in an error:

root@server1:~# apt-get install python-letsencrypt-apache -t jessie-backports
Pakketlijsten worden ingelezen… Klaar
E: Een waarde ‘jessie-backports’ voor APT::Default-Release is ongeldig, aangezien een dergelijke uitgave niet voorkomt in de bronnen

This dutch and means:
Package lists are read … done
A value ‘Jessie-backports’ for APT::Default-Release is not valid, since such an issue is not present in the sources.

What can I do to successfully install certbot with apt-get on my Debian 8.4 (Jessie) with Apache 2.4.


#2

Try this guide: https://backports.debian.org/Instructions/


#3

Oh yes ofcourse thank you. I never used backports before.
Oke wen i create the /etc/apt/sources.list.d/backports.list and run apt-get update i tried the certbot install command again this time again a error:

Sommige pakketten konden niet geïnstalleerd worden. Dit kan betekenen
dat u om een onmogelijke situatie gevraagd heeft, of, indien u
de distributie ‘unstable’ gebruikt, dat sommige benodigde pakketten nog gemaakt moeten worden of uit ‘Incoming’ verwijderd werden.
De volgende informatie kan misschien helpen de situatie op te lossen:

De volgende pakketten hebben niet-voldane vereisten:
_ python-letsencrypt-apache : Vereisten: letsencrypt (>= 0.5.0~) maar het zal niet geïnstalleerd worden_
_ Vereisten: python-letsencrypt maar het zal niet geïnstalleerd worden_
E: Kan problemen niet verhelpen, u houdt defecte pakketten vast.

This is again in dutch below the google translation:

Some packages could not be installed. This can mean
You have requested an impossible situation or if you
use the distribution ‘unstable’, that some required packages have yet to be made or were removed from “Incoming”.
The following information may help to resolve the situation:

The following packages have unpaid requirements:
_ python-letsencrypt apache: Requirements: letsencrypt (> = 0.5.0 ~) but it will not be installed_
_ Requirements: python-letsencrypt but it will not be installed_
E: Unable to correct problems, you have held broken packages.


#4

I see this error as well. It seems the python-letsencrypt has gone missing from the backports repository.

apt-get install letsencrypt -t jessie-backports
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
letsencrypt : Depends: python-letsencrypt (= 0.5.0-1~bpo8+1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


#5

Same problem here but:

python-letsencrypt:
Installed: (none)
Candidate: 0.5.0-1~bpo8+1
Version table:
0.5.0-1~bpo8+1 0
100 http://ftp.fr.debian.org/debian/ jessie-backports/main amd64 Packages
is available, in the right version, i check for all the dependencies and all of theme are present, in the right version…

edit: Strange, i edit my source.list to set an official repo (from ftp.debian.org to ftp.fr.debian.org). Then apt-get install letsencrypt -t jessie-backports always give me an error but when i type

apt-get install -t jessie-backports certbot

everything goes fine (except for the python-letsencrypt-apache):

1 mis à jour, 27 nouvellement installés, 0 à enlever et 50 non mis à jour.

(sorry forgot the LC_ALL=C option :s)

hope it can help you =)


#6

Hello everyone!

Sorry about that; the upgrade in backports took a bit longer than expected, so we ended up breaking some installs over the weekend.

You should be able to install everything correctly with:
apt-get install -t jessie-backports certbot or
apt-get install -t jessie-backports certbot python-certbot-apache, depending on whether you need Apache support.


#7

Thank you sir.

A moment ago I run:
apt-get update
apt-get autoremove
apt-get autoclean
apt-get install -f
Then
apt-get install python-letsencrypt-apache -t jessie-backports

Still the same outcome.


#8

The packages were renamed. You’ll need to replace “letsencrypt” with “certbot” in your apt-get command.


#9

Oh yes duh shame :S

I did copy/paste from https://certbot.eff.org/#debianjessie-apache

Of course now it worked 100% with:
apt-get install -t jessie-backports certbot python-certbot-apache

Thank you!


#10

This has not been updated in the generator: https://certbot.eff.org/

Any idea who maintains this / how to submit patches?


#11

I still get this error when running the apt-get command above:

The following packages have unmet dependencies: certbot : Depends: python-certbot (= 0.8.0-1~bpo8+2) but it is not going to be installed python-certbot-apache : Depends: python-certbot but it is not going to be installedE: Unable to correct problems, you have held broken packages.


#12

Hello @ws62003,

Take a look to this post, he is fixing it right now.

Cheers,
sahsanu


#13

I’m still getting the same problem described here, even though I enabled the backports.

I’ve done:

  • adding this to /etc/apt/sources.list.d/backports.list:

      deb http://ftp.debian.org/debian jessie-backports main
    
  • enabling the backports:

      sudo apt-get update
    

but I still get the error.

$ sudo apt-get install -t jessie-backports certbot python-certbot-apache
Reading package lists... Done
E: The value 'jessie-backports' is invalid for APT::Default-Release as such a release is not available in the sources

The order of the arguments don’t change the result, apt-get install python-certbot-apache -t jessie-backports and apt-get install -t jessie-backports python-certbot-apache results the same.