Bunch of errors


#1

Hi!

Sorry about the vague error description, but I’m getting the following error constantly, when trying to use any commands related to letsencrypt or certbot:
Traceback (most recent call last):
File “/usr/bin/letsencrypt”, line 5, in
from pkg_resources import load_entry_point
File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 2876, in
working_set = WorkingSet._build_master()
File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 451, in _build_master
return cls._build_from_requirements(requires)
File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 464, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 639, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: psutil>=2.2.1

Even the command letsencrypt --version produces the same error.
I’ve tried reinstalling it, but unfortunately the results are exactly the same.
I’m running it on a Debian 8 server.

Anyone experiencing the same issue?


#2

Someone has actually posted this issue on Debian mailing list earlier today I believe:

https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1428260.html


#3

I downloaded the certbot-auto instead (https://dl.eff.org/certbot-auto), which worked just fine.
Hope that the package will be fixed soon :slight_smile:


#4

I can confirm that this issue has been fixed! =)


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.