Hey, i’ve started using the letsencrypt python client today.
But when I launch
./letsencrypt-auto --server .... some of the required packages could not be installed. I’m running Ubuntu 14.04LTS and apt told me that I have unmet dependencies:
The following packages have unmet dependencies: libffi-dev : Depends: libffi6 (= 3.1~rc1+r3.0.13-12ubuntu0.1) but 3.1-2+b2 is to be installed libssl-dev : Depends: libssl1.0.0 (= 1.0.1f-1ubuntu2.15) but 1.0.1k-3 is to be installed Depends: zlib1g-dev but it is not going to be installed python-dev : Depends: python (= 2.7.5-5ubuntu3) but 2.7.9-1 is to be installed Depends: libpython-dev (= 2.7.5-5ubuntu3) but it is not going to be installed Depends: python2.7-dev (>= 2.7.5-1~) but it is not going to be installed E: Unable to correct problems, you have held broken packages.
I know that this has sth to to with the package sources, so I post my sources.list even:
deb http://archive.ubuntu.com/ubuntu trusty main restricted universe multiverse deb http://archive.ubuntu.com/ubuntu trusty-updates main restricted universe multiverse deb http://security.ubuntu.com/ubuntu trusty-security main restricted universe multiverse deb http://archive.canonical.com/ubuntu trusty partner
I can’t solve this problem alone and I a similar a time ago with another service that runs on python and asked on askubuntu but I never recieved an answer.
Maybe somebody here can help me?
(I know that the problem is not on the side of letsencrypt or python but I asked anyway here because I dont know what to to otherwise… ^^)