Unmet dependencies


#1

Hey, i’ve started using the letsencrypt python client today.
But when I launch ./letsencrypt-auto --server .... some of the required packages could not be installed. I’m running Ubuntu 14.04LTS and apt told me that I have unmet dependencies:

The following packages have unmet dependencies:
 libffi-dev : Depends: libffi6 (= 3.1~rc1+r3.0.13-12ubuntu0.1) but 3.1-2+b2 is to be installed
 libssl-dev : Depends: libssl1.0.0 (= 1.0.1f-1ubuntu2.15) but 1.0.1k-3 is to be installed
              Depends: zlib1g-dev but it is not going to be installed
 python-dev : Depends: python (= 2.7.5-5ubuntu3) but 2.7.9-1 is to be installed
              Depends: libpython-dev (= 2.7.5-5ubuntu3) but it is not going to be installed
              Depends: python2.7-dev (>= 2.7.5-1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I know that this has sth to to with the package sources, so I post my sources.list even:

deb http://archive.ubuntu.com/ubuntu trusty main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu trusty-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu trusty-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu trusty partner

I can’t solve this problem alone and I a similar a time ago with another service that runs on python and asked on askubuntu but I never recieved an answer.
Maybe somebody here can help me?
(I know that the problem is not on the side of letsencrypt or python but I asked anyway here because I dont know what to to otherwise… ^^)
Sincerely,
Levin


#2

It should work on Ubuntu 14.04.

Did you try to resolve the dependency issue?
apt-get -f install

The output you have shown does not show which package or packages have the issue. If “apt-get -f install” doesn’t solve your issue, it should provide enough info to solve the issue.


#3

apt-get -f install does not affect the output…

root@levinus:~# apt-get -f install git   python   python-dev   $virtualenv   gcc   dialog   libaugeas0   libssl-dev   libffi-dev   ca-certificates
Reading package lists... Done
Building dependency tree
Reading state information... Done
gcc is already the newest version.
gcc set to manually installed.
ca-certificates is already the newest version.
git is already the newest version.
python is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libffi-dev : Depends: libffi6 (= 3.1~rc1+r3.0.13-12ubuntu0.1) but 3.1-2+b2 is to be installed
 libssl-dev : Depends: libssl1.0.0 (= 1.0.1f-1ubuntu2.15) but 1.0.1k-3 is to be installed
              Depends: zlib1g-dev but it is not going to be installed
              Recommends: libssl-doc but it is not going to be installed
 python-dev : Depends: python (= 2.7.5-5ubuntu3) but 2.7.9-1 is to be installed
              Depends: libpython-dev (= 2.7.5-5ubuntu3) but it is not going to be installed
              Depends: python2.7-dev (>= 2.7.5-1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

#4

Where did you got libffi6 3.1-2+b2, libssl-dev 1.0.1k-3 and python 2.7.9-1?
None of those versions are in the package sources that you listed above and are likely your problem.
Do you have any additional sources in the directory /etc/apt/sources.list.d/ or any PPAs?


#5

This isthe output of cat /etc/apt/sources.list.d/*:

deb http://ppa.launchpad.net/mc3man/trusty-media/ubuntu trusty main
# deb-src http://ppa.launchpad.net/mc3man/trusty-media/ubuntu trusty main
deb http://ppa.launchpad.net/mc3man/trusty-media/ubuntu trusty main
# deb-src http://ppa.launchpad.net/mc3man/trusty-media/ubuntu trusty main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://dl.google.com/linux/mod-pagespeed/deb/ stable main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://dl.google.com/linux/mod-pagespeed/deb/ stable main
deb http://download.opensuse.org/repositories/isv:/ownCloud:/community/xUbuntu_14.04/ /
deb http://download.opensuse.org/repositories/isv:/ownCloud:/community/xUbuntu_14.04/ /
deb http://us.archive.ubuntu.com/ubuntu/ precise-updates main restricted
deb http://us.archive.ubuntu.com/ubuntu/ precise-updates main restricted`

And these sources deactivated I a time ago…

deb http://repo.ajenti.org/ng/debian main main ubuntu
deb http://archive.ubuntu.com/ubuntu quantal main multiverse universe
deb http://archive.ubuntu.com/ubuntu quantal-updates main multiverse universe
deb http://security.ubuntu.com/ubuntu quantal-security main universe multiverse

Probably the problem is not solveable on this way… I thought I could find another way but I think the only is removing and re-installing the affected packages is the only. The big thing is that, for example with removing libffi-dev I remove apache and other important packages. Has anyone an another idea? Let me know…


#6

You downgrade a package by downloading the specific .deb file for you version of ubuntu (for example from http://packages.ubuntu.com/trusty/libffi6) and manually installing it with dpkg -i package_name.deb.


#7

Yes, I downgraded the hole package chain for python-dev, libssl and libffi6 and now the letsencrypt tool works fine! Thanks a lot!