Certbot with Python 2.7.1.2 on Ububtu - Broken Packages


#1

I am now using ubuntu 16.04 and python --version tells me I’m using 2.7.12.
When I try to do sudo apt-get install letsencrypt I now get:

The following packages have unmet dependencies:
letsencrypt : Depends: python-letsencrypt (= 0.4.1-1) but it is not going to be installed
Depends: python:any (>= 2.7~)
E: Unable to correct problems, you have held broken packages.

When I try sudo apt-get install python-pip I get:

The following packages have unmet dependencies:
python-pip : Depends: python:any (< 2.8)
Depends: python:any (>= 2.7.5-5~)
Recommends: python-all-dev (>= 2.6) but it is not going to be installed
Recommends: python-setuptools but it is not going to be installed
Recommends: python-wheel but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

sudo apt-get install python-dev also gives the error:
The following packages have unmet dependencies:
python-dev : Depends: python (= 2.7.11-1) but 2.7.12-1 is to be installed
E: Unable to correct problems, you have held broken packages.

Any help would be much appreciated


APT error with Python 2.7.12 and python-certbot-apache
Getting error in CERTBOT in CENTOS7 - libffi Package Missing
#2

It seems like you don’t have the right dependecies installed. Mainly python. If you install those then run ./certbot-auto it should work.


#3

yes this is what I’m trying but it’s proving to be much more problematic than I expected


#4

hi @Nodeocrat

this is how i would work through this

A) run apt-get update (this gets the latest versions of packages)
B) run python - see what version you are using
C) run apt-get install --only-upgrade python (this should update python to the latest versioN)
D) run apt-get install pyhon-pip (pip is a package manager for python)
E) run the following command sudo apt-get install build-essential libssl-dev libffi-dev python-dev (this provides some needed packages for the cryprtography module)
F) Run pip install certbot

Once it’s all complete you should have certbot running

these are the errors i worked through on an install on ubuntu 14.04

I preffer to use the PIP manager to do the certbot installs (there is also a script and the apt-get method)

It is highly likely that you may run in to other dependency issues please post the screenshots and we will work through them :smiley:


#5

Hey, thanks for the reply :slight_smile:
I am now using ubuntu 16.04 and python --version tells me I’m using 2.7.12… I have updated the OP accordingly.
When I try to do sudo apt-get install letsencrypt I now get:

The following packages have unmet dependencies:
letsencrypt : Depends: python-letsencrypt (= 0.4.1-1) but it is not going to be installed
Depends: python:any (>= 2.7~)
E: Unable to correct problems, you have held broken packages.

When I try sudo apt-get install python-pip I get:

The following packages have unmet dependencies:
python-pip : Depends: python:any (< 2.8)
Depends: python:any (>= 2.7.5-5~)
Recommends: python-all-dev (>= 2.6) but it is not going to be installed
Recommends: python-setuptools but it is not going to be installed
Recommends: python-wheel but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

sudo apt-get install python-dev also gives the error:
The following packages have unmet dependencies:
python-dev : Depends: python (= 2.7.11-1) but 2.7.12-1 is to be installed
E: Unable to correct problems, you have held broken packages.


#6

removing python altogether and instead installing just python-dev fixed it


#7

good :smiley:

also try installing certbot rather than letsecnrypt as i believe certbot is the current client


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.