Installing SSL: Apache on Ubuntu 16.04 (xenial)


#1

I’m unable to install the ssl certificate in Apache on Ubuntu 16.04 (xenial). I’m using as reference this tutorial:

https://certbot.eff.org/lets-encrypt/ubuntuxenial-apache

When a I run

$ sudo apt-get install python-certbot-apache

I get the following error:

The following packages have unmet dependencies:
python-certbot-apache : Depends: python3-certbot-apache but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@ubuntu-s-1vcpu-1gb-nyc1-01:~#

If I run python -V, I get Python 2.7.15rc1 If I run python3 -V, I get Python 3.7.0

I’d appreciate the help please.


#2

Did you upgrade from 14.04/14.10 recently?

What does it say when you try to install that one directly?

sudo apt install python3-certbot-apache

#3

No, this is a new droplet I created on Digital Ocean.


#4

When I run it directly, I get

The following packages have unmet dependencies:
python3-certbot-apache : Depends: certbot (>= 0.26.0~) but it is not going to be installed
Depends: python3-certbot but it is not going to be installed
Depends: python3-zope.component but it is not going to be installed
Depends: python3-zope.interface but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


#5

I tried following those PPA instructions on a Digital Ocean 16.04 droplet in NYC1 and it succeeded:

root@ubuntu-s-1vcpu-1gb-nyc1-01:~# certbot --version
certbot 0.28.0

It seems like that some other software you installed may be be causing the packaging problem.

I looked over this initially, what do-these show?

apt-mark showhold
dpkg --get-selections | grep hold

#6

I ran root@ubuntu-s-1vcpu-1gb-nyc1-01:~# apt-mark showhold
root@ubuntu-s-1vcpu-1gb-nyc1-01:~# dpkg --get-selections | grep hold

but nothing happened.


#7

Any ideas @schoen :confused:


#8

With those Python versions, it sounds like you’re on Ubuntu 18.04 Bionic.

Though installing Certbot should work the same on both…

Are you sure universe is enabled?


#9

The other day, I tried to install Ubuntu 18, but couldn’t complete the task.

I ran a command today and verified universe is enabled.


#10

re"With those Python versions, it sounds like you’re on Ubuntu 1 8 .04 Bionic." How can I just run python 3.7?


#11

What do you mean? Can’t you create a new droplet with Ubuntu 18.04 or 18.10 with a few clicks?

How did you get Python 2.7.15rc1 or 3.7.0 on Ubuntu 16.04?


#12

I installed manually 3.7.0


#13

If necessary, I can create a new droplet.


#14

I would ask @bmw about this.


#15

@bmw any ideas you could share please?


#16

Do you mean you tried to do-release-upgrade and aborted it half way?

That could certainly explain things.


#17

@_az - yes, I’ll create a new droplet.


closed #18

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.