Issues Using Certbot on Ubuntu 14.04.3 Trusty


#1

I am having trouble using certbot on Ubuntu Trusty (14.04.3), it states that I have unmet dependencies that cannot be installed relating to python:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python-dev : Depends: python (= 2.7.5-5ubuntu3) but 2.7.10-1 is to be installed
              Depends: python2.7-dev (>= 2.7.5-1~) but it is not going to be installed
 python-virtualenv : Depends: python-pkg-resources but it is not going to be installed
                     Depends: python-setuptools but it is not going to be installed
                     Depends: python:any (>= 2.7.1-0ubuntu2)
E: Unable to correct problems, you have held broken packages

#2

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.