Need assistance in installing Letsencrypt

Hello Team,

I need assistance in installing letsencrypt on my server. I m using Ubuntu 16.04 Lts, apache2 and have started installation using the following link:
Have been stack when I run the following command:
sudo ./letsencrypt-auto --apache where I get the following error:

The following packages have unmet dependencies:
libffi-dev : Depends: libffi6 (= 3.0.11~rc1-5) but 3.2.1-4 is to be installed
libssl-dev : Depends: libssl1.0.0 (= 1.0.1-4ubuntu3) but 1.0.2g-1ubuntu4.6 is to be installed
Depends: zlib1g-dev but it is not going to be installed
python-dev : Depends: python (= 2.7.3-0ubuntu2) but 2.7.11-1 is to be installed
Depends: python2.7-dev (>= 2.7.3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Have tried to fix on the errors above with no success

Can you please assist me. Thanks

First, the guide you found is outdated and flawed. In multiple ways. First, it installes git to download the letsencrypt-auto. That’s quite unnecessary, as the script can be downloaded (with wget or curl) from (The client name was changed from letsencrypt to certbot a while back ago too…) Secondly, it says you must stop Apache in order to use the apache plugin, which just isn’t true: the apache plugin needs Apache to be running. It’ll probably start Apache itself or quit with an error if Apache isn’t running.

That aside, I’d suggest you just follow the official guide for Ubuntu 16.04 from the official certbot site:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.