Problem installing LetsEncrypt on Raspberry Pi


I am trying to install LetsEncrypt on my Rpi. I am running Jessie with nginx(1.10.3) and MariaDB(10.1), PHP7.0
I cloned to /etc/letsencrypt
When I run /etc/letsencrypt/letsencrypt-auto I get the following output:

The following packages have unmet dependencies:
_ libssl-dev : Depends: libssl1.0.0 (= 1.0.1t-1+deb8u6) but 1.0.2k-1~bpo8+1 is to be installed_
E: Unable to correct problems, you have held broken packages.

I realise that it is something to do with compatibility of builds from the standard repository and the backports repository - I think I had to get some packages from the backports versions - my sources.list file looks like this:

deb jessie main contrib non-free rpi
deb jessie-backports main contrib non-free

I am not sufficiently experienced to know how I can resolve this - any help would be much appreciated.


Norman B

I did Let’s Encrypt on a Raspberry Pi a few weeks ago following this guide, however I did it with Apache, not nginx:

Hope that works

Thanks for the reply, but no joy by that route either - same error message.
Norman B

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.