Problem with let's encrypt install

Please fill out the fields below so we can help you better.

My domain is: private

I ran this command:

It produced this output: can’t install let’s encrypt on this

My web server is (include version): apache 2

The operating system my web server runs on is (include version): debian 8

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The guide is flawed. It uses git which is never necessary for just the installation of certbot.

Please follow the guide(s) on the official site:

when i apply the first command i have

The value ‘jessie-backports’ is invalid for APT::Default-Release as such a release is not available in the sources

i don’t understand why

Did you click on and follow the instructions from the link in the phrase “First you’ll have to follow the instructions here to enable the Jessie backports repo (…)”? You’ll notice the word “here” is a link to click on. (On the instruction page, not in my post…)

yes i’ve clic on it but your tutorial in your link doesn’t install i don’t understand

You mean you don’t understand these instructions?

i understand these instrctions i have done this but i have the same problem

What is the contents of your sources.list?

Did you run apt-get update?

What is the exact output of the command sudo apt-get install python-certbot-apache -t jessie-backports?

this is the content :

deb jessie main contrib

deb jessie-updates main contrib

deb jessie/updates main contrib

deb jessie-backports main

yes i runned apt-get update and i don’t understand your last question sorry

i’ve run apt-get update again and now it works i think it’s fine now :slight_smile: thank you i can execute the other comand lines but i have another problem i dont understand why i have this


  • The following errors were reported by the server:

    Type: unauthorized
    Detail: Incorrect validation certificate for tls-sni-01 challenge.
    from Received 1 certificate(s), first
    certificate had names “

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A record(s) for that domain
    contain(s) the right IP address.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.