Problems with Debian Version 6.0.10


#1

I’m running Debian Squeeze in Version 6.0.10.

I’ve tried to run the Python client and install it, but it don’t work.

When I’m running
./letsencrypt-auto --agree-dev-preview --server \ https://acme-v01.api.letsencrypt.org/directory auth
I get the following output:

/opt/letsencrypt# ./letsencrypt-auto --agree-dev-preview --server \

  https://acme-v01.api.letsencrypt.org/directory auth

Bootstrapping dependencies for Debian-based OSes…

Es wurden 300 kB in 1 s geholt (208 kB/s)
Paketlisten werden gelesen… Fertig
E: Keine Pakete gefunden
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen… Fertig
ca-certificates ist schon die neueste Version.
dialog ist schon die neueste Version.
gcc ist schon die neueste Version.
git ist schon die neueste Version.
libffi-dev ist schon die neueste Version.
python-dev ist schon die neueste Version.
python ist schon die neueste Version.
python-virtualenv ist schon die neueste Version.
libaugeas0 ist schon die neueste Version.
libssl-dev ist schon die neueste Version.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 4 nicht aktualisiert.
Creating virtual environment…

On my Raspberry Pi with Raspian it works fine.

Has anyone an idea to solve the problem on the Debian engine and obtain the certificate?

Thanks for your help!

Andreas


#2

well it tries to update a lot of packages and all say that they are up to date, for the ones who dont undertsand German.

and it stops at the virtual environment? what happens then? back to prompt or does it just stay inside the command and you had to Ctrl+C it?


#3

Unfortunately, Let’s Encrypt currently doesn’t work with Python 2.6 which is used on Debian squeeze (see the thread here for more info).

There are fixes in the works to solve this problem, but currently the project is only supported on Python 2.7. Keep an eye on #1046 and #1078 for updates on the issue.

I’m sorry I don’t have a better answer for you at this time.


#4

Yes, it stops at the virtual environment and went back to prompt.

But I have solved the problem , I have issued the certificate manually on my notebook.

Thanks for your help!


#5

I have the same problem and ended up solving it the same way (by issuing the certificate using my desktop computer). How were you planning to renew your certificates in the future, though? I think it will be a bit inconvenient if I have to do it manually every three months. I could of course make a script that does this with a single command, but I wouldn’t like to make future IT administrators of the small organization I’m in to be dependent on scripts running on my personal desktop to renew the certificate.


#6

I’d say that in this case you should update your OS as Debian 6 LTS ends in February 2016.


#7

There is always the opportunity to just install python 2.7 if you don’t want/need a dist-upgrade messing your business environment. - I’m replying just to get info if this Python 2.6 issue has been resolved or not?