Install LetsEncrypt on GoDaddy Ultimate Linux Hosting

My domain is:

I ran this command: su

It produced this output: no command su

My web server is (include version): apache

The operating system my web server runs on is (include version): Redhat 4.4.7

My hosting provider, if applicable, is: GoDaddy

I can login to a root shell on my machine (yes or no, or I don’t know): no

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): yes, how do you find the name and version of control panel?

I am just confirming … there is NO WAY to use Let’s Encrypt with a GoDaddy shared host plan, right? The shared host does not give root access to the server. GoDaddy has no incentive to make Lets Encrypt work. They have instructions for the virtual private host, however they don’t even both to mention that these instructions don’t work for shared hosting.

I just called GoDaddy support, and the person who helped me had no knowledge of Let’s Encrypt at all, had never heard of the concept.

The shared hosting has CPanel, but browsing through CPanel I seen no support there. Searching the web there is a “CPanel Plugin” for lets encrypt, but as far as I can tell, I have no option to use CPanel plugins, because it appears (I am not sure because none of this documentation is very clear) I need root access to do that.

So I am just CONFIRMING that there is NO WAY to use Let’s Encrypt on a GoDaddy shared host? Or is there a way that I have not tried?

You can use Let’s Encrypt on shared hosting, but you cannot do so in an automated fashion. I’m doing so now for a nonprofit I support until we can migrate them to hardware I own. You will need to manually renew and apply certificates every few months, which is obnoxious, but not too bad. I use the ZeroSSL web client to issue myself, but works too, and doesn’t require root.

You’ll just have to paste the certificate, key, and chain into the control panel certificate manager.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.